2

I have some photos on a linux computer that I would like to add to a Shared iPhotos Album.

So I thought I would log in to my icloud.com account and add them there.

To my surprise, the shared albums are not even listed on my icloud.com account? Why not?

How can I add photos to my shared iPhoto album with a non Apple computer?

UPDATE: My Mac doesn't even show the Shared Albums, even though I use the same account as on my iOS devices.

UPDATE2: I am running MacOS10.13.6

enter image description here

UPDATE3: Thank you @fsb it was indeed an iCloud setting: "iCloud Photo Sharing" that wasn't enabled.

enter image description here

New contributor
Bram is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • You can add them to the iCloud library first? Then share to shared? I’m not sure I get what you’re trying to accomplish - maybe I’m missing something. – bmike Feb 11 at 20:04
1

Shared albums are not available to view on iCloud.com. You can only create albums and add/delete photos in albums on a device and then share a link to them.

You'd have to share your album and send yourself a link in order to see in online.

You can add/delete photos from any shared album while on your Mac. After you do that, any subscribers to that album, Mac or PC, will be able to see the changes you made.

Add items to a shared album

  1. In the Photos app on your Mac, click a shared album under Shared in the sidebar.

  2. Click “Add photos and videos.”

  3. Select the photos, video clips, and Live Photos that you want, then click Add.

  4. Subscribers to your shared album can play the video in the Live Photos.

Remove items from a shared album

  1. In the Photos app on your Mac, click a shared album under Shared in the sidebar.

  2. Select the items you want to remove, press Delete, then click Delete.

  3. Photos removes the items from the shared album, but leaves the original items in your library.

Important: If you delete photos or videos that others added to the shared album, you won’t have copies of them in your library. If you want to keep these items, download them from the shared album before deleting them.

Source

  • I don't have "Shared" in the sidebar on my Mac running MacOS10.13.6 version. See update. – Bram Feb 11 at 20:10
  • You didn't mention your macOS version so I assumed it was the latest. Can you edit your question to add that info as well as the appropriate tag? If you go to the link in my answer, you can change the version dropdown to High Sierra. – fsb Feb 11 at 20:21
  • It has the same instruction for High Sierra: "In the Photos app on your Mac, click a shared album under Shared in the sidebar." – Bram Feb 11 at 20:37
  • 1
    Are you signed-in to iCloud on this Mac? If so, is iCloud Photo Sharing enabled in System Preferences (& Photos Preference, I think)? Is your Photos Library setup as your System Photos Library? This was all a bit complicated in High Sierra, unfortunately. See this link for guidance. – fsb Feb 11 at 21:06

Your Answer

Bram is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.