2

I want to share Internet connection from my iPhone to my Macbook. Before, I just clicked the Wi-Fi icon on my mac and my iPhone automatically appeared there above the line. I did not need to enable personal hotspot on iPhone.

However, I've changed my mobile phone provider recently, and iPhone option no longer appears on Wi-Fi menu automatically without enabling hotspot on the iPhone (see picture). I there a way to make it work like it did before?

I'm aware that there is an option to connect to my phone from the Bluetooth icon, but that's not what I want.

Wi-Fi no iPhone option

Update

I followed @drivec suggestion and it fixed my issue. Here is what I did:

  • Logged out of iCloud both on Mac and iPhone.

  • Rebooted both devices.

  • Logged into iCloud on both devices.

  • Rebooted both devices.

  • Now my iPhone appears in the Wi-Fi menu of the Mac without turning on "Personal Hotspot" on the iPhone, see picture below.

Success!

9
  • 1
    Can you confirm your new provider 'allows' your phone to be a mobile hotspot? My iPhone 7, with AT&T, can be used as a hotspot. My wife's iPhone 7, on Verizon, cannot be used.
    – IconDaemon
    Feb 11 '19 at 1:22
  • 1
    @drivec yes. I rebooted both my Mac and iPhone again now, just to make sure. It did not fix the problem, unfortunately.
    – Evgenii
    Feb 12 '19 at 1:55
  • 1
    @Evgenii Have you tried toggling Handoff off/on for both your iPhone and Mac? support.apple.com/kb/PH25169
    – drivec
    Feb 12 '19 at 18:13
  • 1
    @Evgenii Have you tried logging out of and logging back into iCloud on both your Mac and iPhone? Doing this is a bit of pain, but it would be my next troubleshooting step.
    – drivec
    Feb 15 '19 at 16:53
  • 1
    @drivec yes, logging out and into iCloud on both devices worked, thanks! It was a bit of a pain, you are right. Make it an answer if you want me to accept it. :)
    – Evgenii
    Feb 15 '19 at 23:32
1

The Instant Hotspot is part of Apple's Continuity and Handoff features.

Try each of these troubleshooting steps:

  1. Confirm both devices are logged into iCloud.
  2. Toggle WiFi and Bluetooth off and on for both devices (for iOS, use the Settings app and not Control Center to toggle these settings).
  3. Reboot both devices.
  4. Log out of iCloud on both devices and log back in.

Logging out of iCloud and back in on both devices can be a pain and take some time, so make sure to try the previous steps first. It may or may not be helpful to reboot your devices after both logging out and logging back in.

For this particular situation, the asker indicated that they did the following to solve their problem:

  1. Logged out of iCloud both on Mac and iPhone.

  2. Rebooted both devices.

  3. Logged into iCloud on both devices.

  4. Rebooted both devices.

2
  • I have this exact problem and these exact steps did NOT solve the problem. macos 10.13.6, ios 12.3.1
    – frumbert
    Sep 12 '19 at 9:09
  • @frumbert: Try upgrading your devices to the newest versions of macOS and iOS. Your iOS version is out of date by 3 months and your macOS version is out of date by a full major release (which may be a limitation of your machines's hardware).
    – drivec
    Sep 12 '19 at 18:39
0

The web offers a myriad of solutions to this but most did not work for me. I'll first describe what worked for me and then list the ones that didn't, in case they'll help others that find this.

What helped me: Resetting my Mac's Bluetooth module

My issue was that my Mac had some traces of data in some Bluetooth system that had to be cleared. When I reset my Mac's Bluetooth module my iPhone appeared under the "Personal Hotspots" header in the WiFi menu.

This is what helped me:

  1. Make sure the Bluetooth icon in the menu bar is enabled by checking "Show Bluetooth in menu bar" in System Preferences > Bluetooth.

  2. Hold shift and option and click the Bluetooth icon in the menu bar.

  3. Click Debug > Remove all devices (I did this, I'm unsure if it helped). Note that you will have to reconnect all your devices after this (mice, keyboards, AirPods, ...).

  4. Open the same menu again by holding shift and option and clicking the Bluetooth icon in the menu bar.

  5. Click Debug > Reset the Bluetooth module.

This was the only action that solve the problem for me, after trying everything below.

Other solutions I have found online that might help you

The solutions below is what I tried that did not help but that have helped others. Hopefully it will help you if resetting the Bluetooth module did not.

Turn it on an off again

Turn off both your Mac and your iPhone and then turn them on again.

Make sure Wifi and Bluetooth is turned on

Just to make sure, enable both WiFi and Bluetooth on your Mac. Bluetooth is used to mediate between the phone and the computer and setup the WiFi network used for the Personal Hotspot, so Bluetooth needs to be enabled.

Also make sure Bluetooth is enabled on your phone and that its not in Airplane mode.

Reset Network Settings

This will restart your iPhone. I lost no data doing this and did not notice any difference. In particular it did not solve the Personal Hotspot problem in my case.

  1. Go to the Settings app > General > Reset > Reset Network Settings.
  2. Your iPhone will restart.

Sign out of iCloud on your iPhone

You need your iPhone password and iCloud password to do this. I did this without losing any data, but it did not solve the Personal Hotspot problem.

  1. Go to the Settings app > Your name at the top > Sign out (at the bottom). NOTE THAT THIS WILL SIGN YOU OUT OF ICLOUD AND REMOVE ICLOUD DATA ON YOUR PHONE.
  2. Sign in again to get your data back.

Sign out of iCloud on your Mac

I needed my iPhone password (yes, the iPhone password), Mac password and iCloud password to do this. I did this without losing any data, but it did not solve the Personal Hotspot problem.

  1. Go to System Preferences > Apple ID > Overview and click Sign out (at the bottom). NOTE THAT THIS WILL SIGN YOU OUT OF ICLOUD AND REMOVE ICLOUD DATA ON YOUR MAC.
  2. Sign in again to get your data back.

More information

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .