4

I can no longer use Command + Space inside iTerm2.

I have been using iTerm2 for years, and configured it so that the Command keys acts as the Alt key. I recently applied the security patch for macOS Sierra 10.12.6, and while all other key combinations continue to work, Command + Space is no longer transmitted to the terminal application, which is a pain as it is bound to set-mark in my favorite environment, qemacs.

Where can I change this behavior?

  • set-mark should be ctrl-space. – Thorbjørn Ravn Andersen Feb 10 at 18:17
  • @ThorbjørnRavnAndersen: set-mark is bound to both ctrl-space and alt-space in qemacs. Depending on the next cursor movement, eg: alt-f or ctrl-n, one is more efficient than the other and my left fingers have gotten used to select the quickest. – chqrlie Feb 10 at 22:28
4

The system has defined a shortcut that intercepted this on my mac:

  • commandspace was bound in System Preferences to Select the previous input source in the Input Sources panel of the Shortcuts tab.

This setting might have been in effect already, but since I have only a single input source (US QWERTY keyboard), it may have been ignored before.

In any case, deselecting the shortcut fixed the problem. Since it can be a pain to have to go fishing for a binding in all panels, here is an app (recommended by bmike) that shows you the current live shortcuts in any app as it runs.

  • 1
    Nice answer. I’ll add a handy tool I use to avoid the painstaking process of searching the mac settings to see if a specific key did get nabbed. You do still have to go make a change, but at least you know where the key presses went. – bmike Feb 10 at 17:13

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.