I have 13" MacBook Pro (Early 2011) with Mac OS X 10.7.2. I can't make Find my Mac option in iCloud to work.

I've try turning off and on again the location services as well as the Find my Mac option in iCloud preferences. I've also tried turning off the firewall, but my MacBook Pro just doesn't appear on my iCloud.

location services is enabled

Am I missing some configuration? Any help is appreciated.

  • Do you still need assistance with this question? It would be great to get an accepted answer that is edited into shape so others might know what worked for you. Let's be sure your are OK now as well, too... – bmike Feb 8 '12 at 16:10
  • Yes my problem is partially fixed because the MBP shows on my iCloud, but it appears offline for some strange reason. – Alan C Feb 9 '12 at 18:10
  • It's possible a router firewall is blocking the Find My Mac service. Two questions: What OS are you on, and are there any warnings in your iCloud pref pane? (Maybe post a screenshot of that.) – duozmo Sep 27 '12 at 2:58

Are you sure that Location Services are enabled under System Preferences -> Security -> Privacy? If this is not enabled, Find my Mac will not work.



Here is the explanation from Apple's iCloud Troubleshooting:

I cannot turn Find My Mac on

This can occur if:

  • You are not an administrative user on your Mac. "Administrator authorisation required" will appear under the Find My Mac switch in the iCloud System Preferences pane. Log out of your account, log back in with an administrative user account and try to turn Find My Mac on in that account.

  • Your Mac has an old Recovery partition. "Recovery system update required" will appear under the Find My Mac switch in the iCloud System Preferences pane. From the Apple () menu, choose Software Update and make sure you install the Mac OS X Lion Recovery HD Update.

  • Thanks for the quick response, I did that but unfortunately it did not worked, are you able to see your MBP from the same MBP? Should I try to locate it from another computer? In my location services menu I see that I have another app (flux) that is using location serv. but I can't see iCloud, here is my screenshot – Alan C Jan 3 '12 at 6:05
  • I've updated my answer. Check it out above. – user14395 Jan 3 '12 at 14:24
  • I don't have the "Recovery system update required", but I do see the " MacBook Pro EFI Firmware Update " update so I'll just give it a try and post again, thanks! – Alan C Jan 3 '12 at 22:53
  • 1
    So I updated my MBP with that EFI Firmware update, then signed out from iCloud reboot, then sign in to iCloud again and it worked, now I see my mac, but for some strange reason says it is OFFLINE, the iCloud troubleshoot says that it might be because the computer is asleep or not connected to a wifi or powered off, obviously none of that happens to be my case, did it happened to you also? – Alan C Jan 6 '12 at 20:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .