I am running iTunes 10.5.2 (11) on Lion 10.7.2 and I have an iPhone 4. Several times now I have created a playlist on my phone and the next time I sync to my mbp, itunes blows away the playlist on the phone. I had expected that iTunes would copy the playlist to the computer. Is there a way that I can prevent these playlists from being deleted?

  • Do you wish strictly to prevent the playlists from being deleted from your phone, or are you looking to sync them to the computer as well? – Dan J Dec 31 '11 at 0:03
  • At a minimum the former, ideally the later. – Rick Dec 31 '11 at 20:06
  • Actually for me the playlists I create on my 4S are copied to the computer and I am pretty sure they also did for my iPhone 4. Perhaps it is something about the sync settings? I have iTunes set up to sync selected lists and artists and playlists created on the phone are automatically added to the selected lists when syncing. – Turismo Jan 2 '12 at 22:57
  • Turismo that is how mine is setup too. – Rick Jan 6 '12 at 2:04
  • @Rick now that is weird. Seems we have to find out what is different in our setups. Are you using the wifi syncing or do you use the cable? If cable: do you sync automatically are do you trigger the sync manually. Seems weird that that should have an impact but I am running out of ideas... – Turismo Jan 6 '12 at 19:10

Might not be the perfect solution, but iTunes Match will sort this. I create on the fly playlists all the time when I'm out, and they're immediately available on other devices.


It sounds like you have 'playlists' ticked in your syncing preferences and that iTunes is overwriting your playlists with no playlists as it syncs from the computer.

First thing to do is to check that Playlists are not being synced under the device in iTunes and Music. Uncheck "sync playlists" and try again.

  • 1
    Yes I am syncing playlists as my music library is larger than I have room on my iPhone. Is this the only way to prevent this? – Rick Jan 6 '12 at 1:50
  • yes, you could always use iTunes match, or sync artists instead using the same menu. – Graeme Hutchison Jan 6 '12 at 7:31
  • @Graeme for me the playlists created on the phone are synced although I also have 'playlists' ticked in the sync settings – Turismo Jan 6 '12 at 18:10
  1. Create a new playlist on the iPhone and add some songs to it
  2. Connect the iPhone to iTunes
  3. From the Summary tab in iTunes, check the "Manually manage music and videos" then click "Sync"
  4. The playlist should appear under your iPhone entry in iTunes now
  5. Now uncheck the "Manually manage music and videos"
  6. Navigate to the Music tab and check "Sync Music and Entire music library"
  7. Sync again and the playlist will appear in your iTunes library.

I am not sure whether this is some kind of bug but it worked for me by following the above instructions.

Otherwise iTunes would delete the contents of the iPhone-created playlist upon sync without following the above steps.

  • If like me, you always have "Manually manage music and videos", pressing the sync button is the way to get your new playlists to appear in iTunes. It seems strange to me that without pressing sync, any changes you make to existing playlists are reflected between the phone and the PC, but adding new playlists isn't. – teedyay Dec 16 '16 at 11:46

This drove me mad when I inadvertently deleted all my playlists...

Unplug iPhone from PC. in your iPhone: Go to Settings - Music - then Turn off iCloud music library.

When you reconnect your iPhone to PC - should now be able to select the music tab under your mobile device in iTunes and select which playlists you want to sync. voila! they should be back on your trusty phone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .