I am having a little trouble with my wireless keyboard.

In the past 3 weeks it has disconnected 3 times and then reconnected after a few moments. The Magic Mouse is working fine alongside it, and the power is up over 70%.

Any advice for when this happens or why this happens would be appreciated.

  • 1
    This is kind of "normal" every now and then, bluetooth is not very reliable. However, if you have a cellphone, a wireless mouse, a Wi-Fi connection, plus there are other possible sources of "wireless noise", it can happen. I suggest you try with new batteries (maybe one is failing and the power is not ok, despite the charge). Other than that, there isn't really much you can do. Did you completely power off, removed batteries, powered on, re-tethered the key, etc.? – Martin Marconcini Dec 30 '11 at 23:08
  • This problem is becoming worse, It disconnects at least once per use. Any help will be appericated. – Graeme Hutchison Jan 3 '12 at 9:37
  • have you tried new batteries I suppose? – Martin Marconcini Jan 4 '12 at 14:35
  • Is this Bluetooth loss of connection problem fixed? On which version of the system was it happening? – dan Sep 16 '12 at 21:14

Mine did this for a bit - turn it off, pull out the batteries, and turn it on again. Failing that, un-pair it from your computer (ideally, pair it with something else too) and then re-pair - this solved my problem (although it was never as regular as yours).

  • 1
    Unpair and re-pairing did it for me too. – Global nomad Jan 3 '12 at 15:42
  • This worked for me, although I must admit I put the batteries back in the wrong way and It wasn't working. Got really confused then! :) – Graeme Hutchison Jan 4 '12 at 21:53

It seems like Apple is aware of this happening now and then, and has built some support into Mac OS X to minimize the problems. They call it "Favourites". It basically means that the OS will prioritize re-pairing the favourited device if it looses connection with it.

Visit Apple Support for more info: http://support.apple.com/kb/TA21371


Finder > Search > Type

If your keyboard mysteriously fails to register key presses while working in an app, try this workaround:

  1. Switch to the Finder.
  2. Click in the Search field, and type. Type anything, such as tttt. Text will appear.
  3. Switch back to your app, and all is well, try typing again.

This has worked for me many times on different Macs with different versions of macOS and with different keyboards

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .