2

MacOS Sierra MacBook Pro mid2012

I disabled kext signing (to use change some icons in liteicon, which I never got to), and pretty soon some of my keys didn't work like they should. I then enabled it, and rebooted it. As soon as I logged in, some keys no longer did what they should do. The keys that are affected are i, j, k, l, m, o, u, and I don't know if any non-letter keys are affected.

I have noticed that the i key functions as cmd+o, and some of the other keys do stuff too (but I don't know what).

Is there any way that I can fix this? This is my school computer (I'm currently doing this at school), and I really need my computer working.

SIP and root are enabled, and so is kext signing currently.

Also, idk if it matters here but Finder keeps crashing (not responding) when I do minor things like clicking on folders when logged into my user account.

Interestingly enough, this only happens on my user account, not on root.

2

This is an issue with accessibility settings. The function is called "Enable Mouse keys". It is configured in Settings - Accessibility - Mouse & Trackpad (left pane option), "Enable Mouse Keys" AND ALSO via the "Options..." button.

There is a checkbox setting "Press the Option key five times to toggle Mouse Keys". If this is active then simply pressing the option key 5 times will activate or deactivate this feature thus changing the functional mode of your keyboard.

https://www.youtube.com/watch?v=wxSo1xnxL_k

  • 1
    Thanks, I didn't realize that I had mouse keys enabled – Sam Feb 8 at 0:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.