0

I'm unable to clear the NetBIOS and Workgroup names (when I try, the current NetBIOS name appears grayed out, and always returns, even after I press "Apply"). I've already issued the command

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.netbiosd.plist

I don't have any file sharing enabled, nor is there an active directory configured.

  • See this answer. There's also no need to remove the netbios plist. Out of curiosity, if you're not using it, why are you trying to change/delete it? – Allan Feb 7 at 11:36
  • Thanks, but I couldn't find anything on that page that applies to NetBIOS. I would like to remove the WINS name for the sake of … removing the reference? It's pretty clear that the NetBIOS name is stored in /Library/Preferences/SystemConfiguration/com.apple.smb.server.plist However, after deleting the file and restarting, it was restored. How can I make this change permanent? This seems to be a common problem, judging from searches on the internet. – odysseus Feb 7 at 22:55
1

Turns out that the solution was to

  1. Remove all the NetBIOS name entries in /Library/Preferences/SystemConfiguration/preferences.plist (there was one for every interface)
  2. Killall -9 cfprefsd
  3. Issue the

    sudo defaults delete/Library/Preferences/SystemConfiguration/com.apple.smb.server.plist

    command for good measure.

  4. Restart

I hope this can help others.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .