I am using Emacs (Version 24.0.50 (9.0) -- Cocoa) on OSX Lion. Whenever I type a TextExpander abbreviation, the snippet does not successfully expand. I hear the audio notification from TextExpander indicating that it tried to expand and the abbreviation I typed is erased from the buffer, but the expanded snippet never appears. I have tried this with "--no-init-file" so I know it is not a conflict with my particular Emacs configuration. Some older tips I have found suggest mapping Command-V to 'yank. This does not work for me.

Does anyone know if there is a way to make TextExpander work in Emacs 24?

Note: I know TextExpander works in Aquamacs and I know about textexpander-sync-el, but both of those cause other problems for me and, if at all possible, would prefer a solution that doesn't involve those two things.

1 Answer 1


I would suggest that even though emacs is running as a Cocoa application, it is not necessarily using a standard Cocoa text input box / field, due to the complexities of a emacs enviroment. So emacs in this case is probably more similar to a X11 program wrapped into a Cocoa gui and does not know how to communicate with TextExpander.

As referenced from TextExpander Support, but anyways contact their support to get the definite answer.

Does TextExpander work with Java, X11, and/or Parallels?

Not at this time. Mac OS X's assistive devices key logging does not support these environments. TextExpander relies on assistive devices key logging to capture keystrokes and so does not work in these environments. We continue to explore ways we might support these environments in a future version of TextExpander.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .