0

I am trying to understand why Remote Management (vnc) is not working on my iMac. I enable Remote Sharing via GUI on Sharing "Remote Management."

when I request "telnet localhost 5900" I get an answer. when I request "telnet 4-digit-ip 5900" I get no response.

Normally, I would think that my firewall is blocking it, but the firewall is off.

A portscan tells me that 22 (ssh) and 3283 (net assistant), as well as a couple of high ports (like Dropbox) are open, but nothing else.

I tried allowing access for everyone or just for me. I have tried "Anyone may request permission" or not. Are there other plist etc options that need to be switched on, that might have been accidentally turned off?

1

I did two things in sequence, which cleared up the problem. First,

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -users admin -privs -all -restart -agent -menu

Second, in the GUI, I turned off remote management and turned on screen sharing. now port 5900 responded. Next I turned off screen sharing again and turned on remote management. Now it is still responding.

Probably a bug in macos...

  • It's no bug - it's expected behavior. Remote Management is ARD. Screen Sharing is well...screen sharing. – Allan Feb 5 at 19:49
  • the bug is not the command, but the need to switch away and then switch back. – ivo Welch Feb 6 at 22:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .