I have been using my Mac Book Pro (15" Lion, latest version) for coming on a year. I used to open the cover, it would search for my wifi, and in 15 seconds I could start web surfing.

Suddenly, in the few weeks though, it is doing something strange...

It still finds the wifi connection in a few seconds (the Wifi icon shows all dark), but now it takes an extra 90 seconds plus until I can actually load anything in a browser.

I noticed that Skype connects after about 90 seconds, then a few seconds later Safari allows me to start loading web pages, and then a few seconds later Chrome will let me start loading web pages.

Very nerve wracking! Any suggestions for diagnosing this or speeding this back up again?

  • 2
    Open System Preferences to the Network pane, turn off WiFi. Turn it back on and note how long it takes to receive an IP address, then let us know. Dec 30, 2011 at 16:31
  • Strange - even when the wifi is turned off, ifconfig shows me an ip address, then when I turn Wifi back on, and wait for the connection, the IP address is the same. In fact, when I close my machine for a few minutes and come back, it is still the same ip Jan 1, 2012 at 1:27
  • One interesting event occurred - I went out of town for a few days, and the Mac immediately connected to my room Wi-Fi. So me says, this proves the problem was with my home router. However on return home, my Mac is now connecting faster than ever to my home Wi-Fi. WTF? Jan 19, 2012 at 23:05

4 Answers 4


You can also boot up to the start up disc that come with your mac if it is 10.6 of newer. There you can connect your wifi when the disc has loaded up to check make sure its not a software issue.

You can also try resetting the P-Ram on startup, by holding P + R + cmd + alt and letting its chime 3 or 4 times. That may help.

Also check with other machines to see how long it takes to receive an ip address. This may be an issue with the router.


This could be the same Lion WiFi issue that has been mentioned by Dan Benjamin in The Talk Show podcast, in which case switching off Bluetooth may be a workaround, although it doesn't work for everyone.

  • My Bluetooth is not on, but the Wifi always exhibits this slowness Jan 1, 2012 at 1:26

You might try running namebench to see if your current DNS entries are either outdated or else now slower than you're used to - it's a great utility anyway.

Just to be thorough I'd try creating a new Network 'Location,' disabling all other network ports, and then joining your wireless - not that it should make a difference, but here you are.


I would definitely try deleting the Wi-Fi network you are experiencing the described problem with. Sometimes MacOS starts acting strange on networks it has credentials stored for for a long time.

To do this, go to System Preferences -> Network -> Wi-Fi -> Advanced -> Wi-Fi. Then, press the minus sign when your network name is selected to delete it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .