Today I encountered a problem with the screen-saver, in which it couldn't be deactivated in order to return to normal work. Normally, hitting escape will deactivate the screen-saver, but this did not work. I could see the mouse pointer over top of the screen-saver, however.

I use hot-corners to activate the screen-saver, and I could still use those to re-activate the screen-saver, but then the escape key brought me back to the screen-saver "underneath", instead of the normal desktop. I could also activate mission control/spaces, and it looked normal, but choosing a desktop just brought me back to the screen-saver.

So, a summary of strategies I tried to get the screensaver "unstuck":

  • hitting escape
  • moving the mouse
  • re-activating and de-activating the screensaver via its hot corner
  • activating mission control with a hotkey and choosing a desktop
  • hitting cmd-opt-escape to try the force quit dialog

How can the screensaver be deactivated without shutting down the machine? I'm running MacOS 10.13.4.

  • To clarify... you mean the screen had locked but the screensaver was still running, rather than it going to a black screen? If so, I've seen that on a few Macs since High Sierra; for some reason the 'screen off' is not being triggered correctly.
    – Tetsujin
    Commented Feb 4, 2019 at 7:44
  • 2
    @Tetsujin The screensaver was still running, even though I was interacting with the machine and trying to get it to shut off Commented Feb 5, 2019 at 20:32

7 Answers 7


I encountered this problem for the last two days on Catalina on my iMac. I tried some suggested methods, but lacked an Apple keyboard, and didn't restart or use SSH.

What eventually worked for me, I didn't find elsewhere:

  1. Ctrl+Cmd+Q
  2. Esc
  3. login

Hitting Esc makes the screen go black, which I guess cancels the screensaver.

  • That's an interesting one! Thanks for adding it as a solution for non-apple keyboards. So does it take you to a login screen, or just lock the screen and prompt for your credentials? Apple lists Shift-Command-Q as a keyboard shortcut for logging out -- is it possible your non-apple keyboard was mapping to that? Commented May 28, 2020 at 0:50
  • Thanks for noticing a discrepancy. I meant Control Command q. Fixed above.
    – Cyberthal
    Commented May 29, 2020 at 2:35
  • 3
    I have been looking for a solution for a long time about this issue, and your solution is the only one that actually works. Thx for sharing.
    – aadlani
    Commented Nov 13, 2020 at 9:53
  • I’ve been constantly referred to this answer for 100 times
    – HanaKaze
    Commented Mar 9, 2021 at 17:08
  • This is so weird, thank you. It works perfectly for me, but I'm curious, why does this keep happening?
    – tamale
    Commented Oct 18, 2022 at 15:31

If you have SSH enabled on your Mac and access to another computer on the same network you can start a terminal session and kill the screensaver. For example, I would open a terminal on my Linux PC and SSH into the Mac then run the following command:

killall ScreenSaverEngine

NOTE: This will not unlock the session if the screen is also locked. It will simply dim and reappear. This solution only applies after entering the password to unlock the screen but the screensaver does not dismiss.

  • Good idea -- would this require root/sudo? Commented May 17, 2020 at 5:23
  • @spinup no, just the user of the session with the screen saver.
    – Coder Guy
    Commented May 20, 2020 at 22:34
  • This worked when lock/unlock did not.
    – atwixtor
    Commented Jun 19, 2020 at 22:16
  • 1
    This is the best answer if you are using Synergy where you are not using the Mac's mouse and keyboard. Most of the time it kills the screensaver when I unlock the system, but sometimes it gets stuck and this does the trick in an ssh session. +1 Many thanks!!
    – Terrance
    Commented Dec 17, 2021 at 15:41
  • 1
    @Terrance Synergy, yes, me too. I ssh'ed in to the machine and googled to find what I could use to kill the screensaver. This works indeed! Commented Apr 9, 2023 at 17:56

Lock & Unlock the Mac

Use the key-combo Control+Shift+Power on MacBooks or Control+Shift+Eject on Macs with a full-sized keyboard. This will lock the computer, requiring the usual login and password authentication. After re-authenticating, the machine should be back to normal.

Source: UWGB

  • 1
    Curiously, the first did not work with my MacBook Pro just now (no change, just the flowing screensaver and a mouse pointer I could move around), nor did closing the lid which normally puts it to sleep. However, I have a full size USB mac keyboard with an eject button, and your second option did the trick with that.
    – Joel Fouse
    Commented Oct 22, 2020 at 2:03

I've still been having this same issue while using vnc to connect to a local Mac Mini (m1 chip, on Monterrey 12.3.1).

I setup remote ssh, and killing the screen saver with

killall ScreenSaverEngine

Kills the screen saver, but I'm still left with a non responsive black screen.

I then tried to manually lock the terminal by using

pmset displaysleepnow

And it takes me back to the prompt and brings the remote session back to a responsive state.

Definitely not ideal, but the most consistent way out of this issue.


None of the key commands worked for me, but unplugging the machine from USB and power and letting it go to sleep, then waking it up again, did.

Very strange bug.


I had to put my iMac to sleep with Option ⌥+Cmd ⌘+Eject ⏏ in order to dismiss the screensaver and then log in.

Other possible button ways to put your mac to sleep:

  • Press and hold Power for 1.5 seconds
  • Option ⌥+Cmd ⌘+Power
  • Ctrl ⌃+Shift ⇧+Power
  • Ctrl ⌃+Shift ⇧+Eject ⏏
  • Ctrl ⌃+Power
  • Ctrl ⌃+Eject ⏏

After using one of the answers by @Cyberthal or by @CoderGuy to get in, you may want to fix the problem for the future.

As shown here, you need to add 2 preferences to /Library/Preferences/com.apple.PowerManagement.$UUID.plist where $UUID is your "Hardware UUID".

To get your Hardware UUID:

UUID=$(system_profiler SPHardwareDataType | awk '/UUID/ { print $NF }')

Then add these:

sudo defaults write /Library/Preferences/com.apple.PowerManagement.$UUID.plist "AC Power" -dict-add "System Sleep Timer"  0
sudo defaults write /Library/Preferences/com.apple.PowerManagement.$UUID.plist "AC Power" -dict-add "Display Sleep Timer" 0

And reboot for the settings to take effect.

  • For me, this was a one-off problem that didn't happen again, as far as I can recall -- what problem is this fix correcting? is it specific to remote desktop sessions, as in the answer you linked? Commented Aug 8, 2022 at 16:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .