0

I have a mid-2012 MacBook Pro, with root setup and SIP disabled.

I was downloading files today, and suddenly my computer couldn't connect to the internet (it said that it had a self-assigned ip). No problem, I get an ethernet cord.

Later, my apps start freezing, so I restart my computer. When I log in, I got stuck at the login window, but on top of the login window, messages launches. I shut down my computer, restart in Recovery mode, and re-install macOS Sierra (with ethernet to download it quicker).

As soon as it's done, I try logging into my user account. It loads infinitely. I then try logging into my user account and root through the other users option. Doesn't load.

Is there any way to login? I've never had this problem before, though I periodically have to re-install macOS Sierra.

  • Why do you have to periodically re-install macOS? - By choice? or because the system stops working? – jksoegaard Feb 4 at 8:45
  • Loads more info. For what purpose do you have root enabled and SIP disabled? What sort of files were you downloading today - executables? Can you clarify the two different methods you used to login? Can you boot into Safe Mode? Any reason you're still on Sierra and not upgrading? The original loss of WIFI just sounds like you needed to reconnect to the network. – benwiggy Feb 4 at 10:17
  • @jksoegaard the system sometimes stops launching apps properly (if at all), won't switch windows, has no dock, and similar problems – Sam Feb 5 at 0:47
  • @benwiggy I have SIP disabled because I occasionally change things with the system that are protected (or have apps that do), and I have root enabled because... Uuuhhhh... I had a reason... – Sam Feb 5 at 0:50
  • @benwiggy I remember now it's because I do some ssh stuff, so that way I can login to root and access everything (and modify/move/copy/delete stuff that I usually wouldn't be able to) – Sam Feb 5 at 0:53
0

I fixed it.

I don't know how this affected it, but I put my computer in target mode and accessed it with a 2013 MacBook Air. I ran Disk Utility (it told me that there were no errors), ran diskutil repairVolume disk3s2, and finally removed all tags from the folder/path /private/root. Then I restarted into it from the MacBook Air, and I could successfully login. I don't know which of these steps fixed logging in (maybe removing the tag?), but it works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .