0

I've been following the migration guide for macOS Server and have gotten stuck with the launch .plist for the BIND (named) DNS server. If I name the file the recommended org.isc.named.plist the service will not start on boot, but will run correctly when loaded with sudo launchctl load /Library/LaunchDaemons/org.isc.named.plist. If I rename the file and Label property to anything else it will run correctly on boot.

I have checked if the service is disabled with launchctl print-disabled system and it is not shown.

I have tried on a fresh install of Mojave with only macOS Server installed and was also unsuccessful getting it to run at boot.

  • 2
    You should include the contents of the plist. – not2savvy Feb 3 at 9:16
  • I am having the same problem. I tried the suggested answer but am having no luck. To be specific I first added the Program key entry which is in the “answer” but not in the Apple migration text (just ProgramArguments there). I then removed the -f option to match the plist in the answer. Again no change in behavior: runs after a manual sudo launchctl load ... command but after reboot it doesn’t automatically reload. Did you ever manage to resolve this issue for yourself? – farf May 10 at 20:55
  • @farf I eventually reinstalled the OS which fixed it as a DNS server was the first thing I tried to set up. I suspect a disabled state was saved/cached in some file, but I was never able to find what file it was. – user2248702 May 11 at 15:24
1

Remove the -f option, it's works for me.

<?xml version="1.0" encoding="UTF-8"?>
        <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN"
   “http://www.apple.com/DTDs/PropertyList-1.0.dtd">
       <plist version="1.0">
            <dict>
               <key>Disabled</key>
               <true/>
               <key>EnableTransactions</key>
               <true/>
               <key>Label</key>
               <string>org.isc.named</string>
               <key>KeepAlive</key>
               <true/>
               <key>ProcessType</key>
               <string>Standard</string>
               <key>Program</key>
               <string>/usr/local/sbin/named</string>
               <key>ProgramArguments</key>
               <array>
               <string>/usr/local/sbin/named</string>
               <string>-c</string>
               <string>/Library/Server/named/named.conf</string>
               </array>
            </dict>
       </plist>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .