0

I'm signed into App Store and have an installed version of Logic Pro X that I bought with the same Apple ID that I'm signed in with.

I no longer receive update notifications via the App Store about Logic Pro X updates.

Here is my system info:

  • OS X El Capitan version 10.11.6
  • Logic Pro X version 10.3.3
  • MacBook Pro Retina 15-inch Mid 2015

I can't upgrade to Mojave yet as apparently, Universal Apollo Audio Software doesn't support it yet.

Is my macOS too old to receive updates now? I tried re-installing once before, but that's a lengthy workaround I'd like to avoid.

1

The reason you are not getting update notifications is that your macOS version is no longer compatible for Logic Pro X.

From the specification page:

macOS X 10.12 or later

You are running 10.11.6 and hence your version isn't compatible.

  • 1
    I get notifications of incompatible updates when they are available on the App Store. Can you show a screen shot of this or back up why the OP wouldn’t get the incompatible app notifiication? – bmike Feb 2 at 13:28
  • I've ended up moving the app to trash, and going back to my purchases. Now it only let's me install the last compatible version 10.3.3. My best bet is to upgrade my macOS to Sierra and get the latest Logic Pro X until UA Apollo software supports Mojave I suppose. – Simon Bosley Feb 2 at 15:37
  • @SimonBosley yeah it probably is – user310476 Feb 2 at 15:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .