2

The hard drive on my iMac died & I had it replaced. They installed a new drive, wiped it clean & re-installed the OS. When I brought it home, I went through set up, pointed it at Time Machine, and viola! next memory my machine was up & running.

With one catch...

I can't get any OS updates. It keeps saying it's unable to check for updates, make sure you connected to the Internet.

enter image description here

I've tried rebooting a few times to no avail. I can also connect to websites just fine, including apple.com.

Any suggestions of what to try?

6
  • Who is they? Is it Apple? Or a third party?
    – JBis
    Feb 1 '19 at 2:26
  • Sorry, a local repair shop. It was a Late 2015 iMac and Applecare no longer covered it.
    – Bill
    Feb 1 '19 at 2:29
  • There is probably your issue. iirc, unauthorized parts make apple things not work. Are you able to login with Apple ID to iCloud, iMessage, FaceTime etc.?
    – JBis
    Feb 1 '19 at 2:30
  • Are you able to see a serial number in Apple This Mac > About?
    – JBis
    Feb 1 '19 at 2:33
  • Yep, serial number is there. Able to log into iCloud, etc.
    – Bill
    Feb 1 '19 at 2:35
1

Seems like the App Store may be having some problems today.

https://twitter.com/macrumors/status/1091369924847558658

https://www.apple.com/support/systemstatus/

I experienced the same problem on a Mac mini (2018) running macOS 10.14.2.

Based on the comment from JBis, using softwareupdate --list was useful to confirm that an issue exists.

$ softwareupdate --list
Software Update Tool

Finding available software
The operation couldn’t be completed. (NSURLErrorDomain error -1012.)

On a MacBook Pro running macOS 10.12.6 (Sierra) I was getting similar behavior. The difference on macOS Sierra was that the App Store Updates tab would generate a popup indicating that "An error has occurred", which also included the last line of text from the softwareupdate output.

-1

Try restarting your computer. That solved it for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .