5

I can not install latest versions of Skype and Telegram in my iPhone last day. I have updates in App Store, click update, update was downloaded and installed. But I still have old version of application and App Store still offer to install updates again.

For example, I have Skype version 8.37.98. App Store offer me to install version 8.38.

What I have already trying to do:

  • Remove Skype from iPhone and install it from stratch. Version 8.37.98 was installed and instanly App Store offer me to update it to 8.38 with the same result. How ??? Where iPhone get this old version ?
  • Reboot iPhone. Log out and log in in my AppleId - still same result.
  • Have found old version iTunes for PC and trying to install Skype using it. The same result! My PC have found version 3.18, download it without error and say that it is version 8.37.98 and I can update it again.

Two additions:

  • I can update other applications.
  • I can update Skype on my iPad to version 8.38. This point makes me think that the probleb is not global and I need to fix something in my iPhone.

Do you have the same problem? Is it my problem or it is global problem? What do you recommend to do?

Updated:

  • I have found information that the same issue have different people from different parts of the world.
  • Telegram in the Twitter said that the problem in the Apple side.

Updated2:

  • Look like the problem is fixed now for both applications.
  • I have the same issue with Skype and another app Clearscore which was also updated at the same time as Skype. I’m in the UK. Must be something wrong with the App Store, guessing the app’s are corrupted so the iPhone rejects the update - shame it doesn’t give an error! The iPad will have a different app load, which is probably not corrupted. Skype is a popular app so I’m sure someone will notice and fix this soon. – José De Bardi Feb 1 at 6:45
1

Apple's stores are actually complicated layers of caching and edge servers, so the power off is a good way to get the phone to re-connect to a different "store server".

I would continue to do that or find a somewhat different network to try. For example, if you have another phone with a data plan - tether to that hotspot instead of using WiFi or find a different WiFi.

I don't think it's local to your device - but if you did suspect that still after exhausting the things you can control and waiting it out, you could back up the device and wipe all contents and settings. Then sign in and download only the two apps.

If you still have issues on a newly wiped device, then the store support team is really your next move. If that works, then you know it was a store caching setting - wipe the device again and then restore from the backup and things should be good to go.

Excellent notes and troubleshooting, I think you're close to a solution to these two apps not behaving in the store app for you.

  • Thanks for your answer. I have checked 2 phones of my family - the same problem. We have tried cellural internet and 2 different wifi providers. Looks like it is global issue in Russia. But I have not problem with iPad .... may be it is separate applications for iPhone and iPad. – demas Feb 1 at 4:57

You must log in to answer this question.

protected by Community Feb 1 at 10:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .