I have a Lion 10.7.2 system (on MacBook Air 13" 2011) which doesn't boot anymore after a restart. My HD is encrypted with FileVault 2, and after I click on my username and enter my password, it appears to be logging in but the apple logo turns into sort of a "forbidden" traffic sign, and stops there forever.

So I booted into Lion Recovery to try and repair permissions, but Disk Utility won't mount my Macintosh HD. It doesn't even allow me the option to mount or verify, they're greyed out.

An output from diskutil list recognizes my partition (/dev/disk0s2) as having the type Apple_CoreStorage.

Any way to make my encrypted partition mount?

  • did you find any answer to your question? Same thing has happened to me tonight. Disk util sees the physical drive but will not mount the encrypted drive, all I get when trying to log in is the prohibited sign... Totally shattered, my baby girl is 4 weeks old, just lost photos of her I fear... Seemed to happen when I connected my iPhone 4s for the first time. It froze and wouldn' t mount after that... If I run lion recovery will all data be lost? Thanks so much for help if you can provide, I'm pretty desperate...
    – user18473
    Commented Feb 9, 2012 at 9:58

3 Answers 3


You should be able to unlock or decrypt your FileVault 2-encrypted HD with Disk Utility. I've got a post on how to do this:

Using Disk Utility to unlock or decrypt your FileVault 2-encrypted boot drive:


If unlocking via Disk Utility isn't working, you may need to use your recovery key. I've got another post on how you can unlock using your recovery key using the command line:

Unlock or decrypt your FileVault 2-encrypted boot drive from the command line:


  • Thanks :) Really good guides, but doesn't work for me. When I do diskutil corestorage list, I see the Logical Volume Group named Macintosh HD, but the Physical Volume inside, which is my desired disk, shows Status: Failed :(
    – Dan
    Commented Dec 30, 2011 at 12:48
  • Please post instructions in the answer itself. Sites go down / away, domains change, links change, content moves. Links on their own don't benefit the site in the long run. Commented Dec 30, 2011 at 18:35
  • I'm accepting this cause it answers my question exactly :) however i'm also facing a different problem that prevents the corestorage physical volume from being used, god knows why... But that's a topic for a different question
    – Dan
    Commented Dec 31, 2011 at 14:21

You could try to repair the disk through termainal

e.g. where disk0 will be the partition you want to repair

  diskutil repairVolume /dev/disk0

if you just type in


This will give you a list of options e.g. mounting the drive etc.

Will probably not help but worth a try.


I was having the same issue with 10.7.4 just now and this question and the comments helped but nothing really worked. But I did try using diskutil from the command line and I got it to work. df showed me my mount points of slash:

{dhcp} df
Filesystem    1024-blocks      Used    Avail Capacity  Mounted on
/dev/disk1      243966468 206648460 37062008    85%    /

I used diskutil list to show me my partitions:

{dhcp} diskutil list
      #:                       TYPE NAME                    SIZE       IDENTIFIER
      0:                  Apple_HFS SSD Hard DIsk          *249.8 GB   disk1

Then I was able to do the repair permissions from the command line on /dev/disk1:

{dhcp} diskutil repairPermissions /dev/disk1
Started verify/repair permissions on disk1 SSD Hard DIsk
Group differs on "Library/Java"; should be 0; group is 80
Permissions differ on "Library/Java"; should be drwxr-xr-x ; they are drwxrwxr-x 

I was also able to verify the volume:

{dhcp} diskutil verifyVolume /dev/disk1 
Started file system verification on disk1 SSD Hard DIsk
Checking storage system
Checking volume

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .