0

I have a MacBook pro 2012 which my friend gave me with the hard drive removed so they could keep their data. I have since bought an SSD and installed it but when I boot up I get a flashing question mark. I have reset the ram then I have tried booting to recovery and it downloads data and gets to the end and then the apple logo comes up then it goes to a white screen and stays there.

Any help would be much appreciated?

Does the drive potentially need formatting in a certain way or partitioning? I've read it could be a hard drive cable but trying to not buy anymore parts without confirming that is the issue first.

  • There's dozens of questions here about this topic (some are to the right of this question). Have you searched for answers already provided and tried those? You can edit your question to indicate what you tried. – fsb Jan 31 at 21:51
  • Olly, you can use the Contact Us form to have your accounts merged, so that you can edit your question. – Glorfindel Feb 1 at 9:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.