I have created a couple of Fluid Apps to run Google Calendar and Gmail.

These work fine except that web links launched from them also launch in Fluid itself, rather than in my default browser, which is Chrome.

This is a problem as a lot of the G-Suite stuff doesn't work well in the fluid browser (e.g. google doc links give javascript errors).

How can I get my Fluid gmail app to open links in the system default browser rather than in the Fluid browser?

  • This is not a duplicate as i this case Chrome is the default browser whilst the other question was how to use a non default browser. – user151019 Jan 31 '19 at 17:58
  • Not a duplicate as Mark points out. As noted I have already set my default browser; the question is why Fluid ignores it and opens Safari anyway. Please remove the duplicate markers. – Tom Walker Feb 3 '19 at 17:31
  • 2
    Fluid isn't what you think it is. Fluid isn't ignoring your default browser settings, a Fluid SSB is a browser. Perhaps there's some tool that will wrap Chrome, but Fluid isn't it. – Marc Wilson Feb 3 '19 at 19:22
  • Very good point, of which I was not aware, and I have updated the question to reflect this. It's not Safari that Fluid is using for links, it's the Fluid browser itself. I am ok with Fluid running the original gmail in its own custom browser, but it would be super useful if I could get it to launch links using the default browser. – Tom Walker Feb 6 '19 at 10:44
  • After the recent edits, I believe this question is now a duplicate of : apple.stackexchange.com/questions/52200/… – Todd Ditchendorf Feb 6 '19 at 14:50

You must log in to answer this question.

Browse other questions tagged .