0

I own a MacBook Pro Early 2011 13" i5 2.3 GHz model

Lately as my MacBook was shutting down randomly I fiddled with it a lot and finally I messed with its Wifi.(I do not remember how I did it as I was under a lot of stress and pressure while doing so)

Currently my wifi works only during disk selection stage and once I enter recovery mode (where we see the disk utility ,terminal etc) or boot screen I see the wifi is turned off and even if I try to enable it it just does not turn on.

Kindly help and please see the pictures showing that wifi works during disk selection stage where it can list all the available networks and i can join any using the password, and show how the icon stays after booting but I can't connect/enable WiFi.

Explanation of pictures: CLOCKWISE

-option to jion wifi at disk selection stage -it successfully ahows available networks -etenteredpassword and joined Nirvana successfullly -BUT THE WIFI DOESNOT WORK ONCE I LOGIN TO MY ACCOUNT ...i mena after the booting up of system Things I did to rectify the problem:

  • I have downgraded to Yosemite and changed my motherboard (now the switching off is gone)
  • I remember doing something like that some 801gfile.kext ....for which i used some utility where it checked the missing kext and seems to have replaced the missing ones...but to no avail.
  • reinstalled and clean installed macos

This wifi fiddling I did was on old motherboard. Even on new board the problem remains. The problem first surfaced on the old board.

MY BLUETOOTH WORKS FINE

Accessing internet: Currently i am using ethernet and external usb wifi dongle by tinda to access internet

Answers for comments - i have replaced only the mother board.the wifi card is the same as before.the problem used to be there even with old motherboard. As said the wifi card currently works fine during disk selection stage where i can select different networks and join them..but ones i enter recovery mode or boot the os normal or safe mode the wifi doesnot turn on

-i have the same old wifi cable and card on the current system..only the mother board was changed. the bluetooth works fine..

Kindly help please.....

Nanis-MacBook-Pro:~ Nani$ kextstat | grep -A10 'IO80211'
   46    1 0xffffff7f8180f000 0xab000    0xab000    com.apple.iokit.IO80211Family (730.60) <44 10 7 6 5 4 3 1>
   48    0 0xffffff7f81f1b000 0x1f3000   0x1f3000   com.apple.driver.AirPort.Brcm4331 (800.20.24) <46 44 12 7 5 4 3 1>
   49    2 0xffffff7f81024000 0x73000    0x73000    com.apple.iokit.IOFireWireFamily (4.5.8) <5 4 3 1>
   50    0 0xffffff7f815f3000 0x27000    0x27000    com.apple.driver.AppleFWOHCI (5.5.2) <49 12 7 6 5 4 3 1>
   51    0 0xffffff7f8253d000 0x13000    0x13000    com.apple.driver.AppleSDXC (1.6.5) <16 15 12 5 4 3 1>
   52    1 0xffffff7f814fb000 0x7000     0x7000     com.apple.iokit.IOEthernetAVBController (1.0.3b3) <44 5 4 3 1>
   53    0 0xffffff7f81502000 0x39000    0x39000    com.apple.iokit.AppleBCM5701Ethernet (10.1.3) <52 45 44 12 11 6 5 4 3 1>
   55    0 0xffffff7f817ea000 0x18000    0x18000    com.apple.iokit.IOAHCIBlockStorage (2.7.1) <39 16 6 5 4 3 1>
   56    0 0xffffff7f812be000 0x1c000    0x1c000    com.apple.driver.AppleUSBHub (705.4.2) <41 5 4 3 1>
   57    0 0xffffff7f82321000 0x3000     0x3000     com.apple.driver.XsanFilter (404) <16 5 4 3 1>
   58    0 0xffffff7f8224d000 0xa000     0xa000     com.apple.BootCache (36) <7 6 5 4 3 1>

enter image description here

  • I can feel the stress and pressure you were under through your post haha. Is the first picture saying all tests passed? You can't refer us to the pictures for details and then post some with no detail in them... – user3052786 Jan 31 at 7:10
  • Welcome to AskDifferent, please take a moment to review the help section on Asking a Question. Please refrain from posting in all caps as it makes it very difficult to read. – Rushil Srivastava Jan 31 at 7:12
  • How exactly did you fiddle with your Wifi? – nohillside Jan 31 at 7:13
  • i used terminal to disable wifi card and some things i donot remeber. – nani1951 Jan 31 at 7:16
  • i wanted to show through pictures that 1) wifi works during disk selection stage where it can list all the available networks and i canjoin any using the password 2)the other picture show how the icon stays after booting ...how much ever i try to on it it just doesnot respond. – nani1951 Jan 31 at 7:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.