I have a 27" Late 2013 iMac with 8GB RAM and a NVIDIA GeForce GTX 775M (2GB) GPU.

Last year my iMac started crashing now and then. Not only that, when it's in sleep mode it just falls out. I have to pull the wire out and in again and then it works again. Very annoying.

I brought it back to the store and they did a hardware check, nothing was wrong apparently.

They looked into the logs and saw that before my iMac crashed the 'Steam -app' was mentioned. So they suggested that I have to reinstall the iMac. Weird I know. So I asked a friend to do that for me since I'm too afraid to make a mistake.

So the iMac was clean and yet again after a few hours it crashed. I downloaded software to see if the fans were working right or the temperature was too high. Again no problems. I used the console to get the CPU to work 100% to see if it would crash. Nope.

So I thought maybe it was the power supply and I tried a different cable. Nope

I looked into the log again and now I see that the last crash was because of com.apple.dictionaryServiceHelper??

I uploaded a screenshot of this: (log+About This Mac)

I'm no iMac expert at all so I just don't know what to do anymore.

How can I continue troubleshooting this?

  • Welcome to Ask Different. Screenshots of the crash/console log don't really work for people trying to analyze the text. Can you edit your post to add the text directly into your question?
    – fsb
    Jan 30, 2019 at 16:54
  • Crash can mean a lot of things. Did you see a screen with many languages? Jan 31, 2019 at 0:34
  • No I have not seen that. To be honest I think it maybe can be the power supply inside de iMac. Because these symptoms are the same as a few years ago. Feb 1, 2019 at 9:27

1 Answer 1


I think this is a CPU power transistor failure. After doing some research, I noticed that 2013-2015 Macbooks had a similar issue. The transistors that switch the CPU from high to low power are too slow in heat and don't switch fast enough, causing a crash. The solution that fixed it for me was to install Macs Fan Control and set this rule: enter image description here

This seemed to fix the issue for me. As happened to you, random processes, such as Word and kernel_task were being named the culprit.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .