2

After upgrading to the latest Mojave update [10.14.3[, I got this error prompt when attempting to sync my calendar.

A snapshot of the error message

Temporarily, I'm using Fantastical as my Calendar, But really prefer the Calendar.app over Fantastical.

Anyone got it too? How should I fix this?

Thanks in advance!

1

Sign out of iCloud

To fix this sign out of iCloud in the preferences pane. No data will be lost and all will be retrieved when you sign back in again. If you use iCloud Keychain, when you sign back in to iCloud follow one of the procedures described in this Support article to set it up on an additional device.

If that doesn't work

If signing out and in of iCloud doesn't work there are several other options you could try.

Re-enabling the calender account

You could try re-enabling the affected calender account. From the Calendar menu bar, select Calendar ▹ Preferences ▹ Accounts.

Choose the affected account from the list on the left and uncheck the box marked. Then check it again to enable the account.

Add the account again with the same settings

You can make a note of the settings for that acxoint, then delete it and add it again with the same settings.

Check your settings

If you can't add the account, the settings may be invalid. Verify them. How you do that depends on what kind of account it is. If it's a Google calendar and you've activated 2-step verification, you need to generate an application-specific password in your Google account and enter it in place of your old password.

  • Have tried all of the steps you mentioned, still no luck :( Thanks for the help though! – Jonathan Filbert Jan 30 at 16:13
  • @JonathanFilbert no problem. Have you tried updating your Mac or rebooting it? – user310476 Jan 30 at 17:41
  • Yes I have, multiple of times. And right now my Mac is in the latest version of Mojave. Still no luck. – Jonathan Filbert Feb 1 at 8:42
  • Also getting this same issue. Eventually the calendars will refresh, but it sometimes takes a very long time. Not sure what the cause of this is, but I'm getting it on both of my machines running MacOS Mojave 10.14.3. – CoBrA2168 Mar 22 at 1:33
  • Logging out of iCloud from a computer (Mojave, remember?) when one's Documents and Desktop folders are on the iCloud is a very bad idea, because that will make a local archive and remove the Document and Destop folders from the computer. – van frunikan May 24 at 11:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .