5

I've a problem that drives me crazy. My company has a wifi network that, when connected, does not allow me to connect to several services. For this to work, I need to connect by Ethernet (changing this is btw no option :D)

I've purchased, some weeks ago, a USB-C thunderbolt dock for my 2018 MBP with an Ethernet port. This port shows up in System Settings -> Network and I can easily disbale wifi and my Mac will use the tethered connection. Sadly, as soon as I connect to the wifi, MacOS will prioritize the wireless connection.

I've moved in System Settings -> Network the Priority of the "Thunderbolt Ethernet Slot 1" to the top, and Wifi below this (even totally at the end!) but MacOS will simply ignore this.

Any ideas in how to debug this?

5
  • I'd try 10.14.3 just in case they fixed it recently.
    – Tetsujin
    Jan 28, 2019 at 11:00
  • Why do you connect to the Wi-Fi if you don't intend to use it? I think MacOS X is overriding your interfaces priority because of this manual connection.
    – dan
    Jan 28, 2019 at 11:03
  • Just updated to 10.14.3, same thing. I use the WiFi as soon as no ethernet is plugged in as a kind of fallback, hence I'd like MacOS to switch this automatically.
    – Jannick
    Jan 29, 2019 at 12:03
  • It worked for me just fine for few years, but now on 11.3 (or even maybe earlier) I am not sure it stopped. I've opened a discussion here: discussions.apple.com/thread/252877960 and just found this was a thing even 10 years ago ;(
    – Valentin
    Jun 18, 2021 at 12:59
  • This continues to be a problem on macOS 13.2.1, unfortunately. Mar 1, 2023 at 15:17

3 Answers 3

2

The Service Order doesn't work. If you test it, you will find that Mac OS prioritizes Wifi over Ethernet, even if Ethernet is set higher in the Service Order.

One way to test it is to measure your bandwidth (e.g., https://www.fast.com) in the following scenarios:

  1. Connected to Wifi, with Ethernet unplugged
  2. Connected to Ethernet, with Wifi turned off
  3. Connected to Wifi and Ethernet

You will find that the speed from #2 is faster than #1 and #3. You will also find that #1 and #3 are the same speed.

The only solution is to disable WiFi when you connect via Ethernet and turn on Wifi when you disconnect Ethernet.

This script does that automatically!

https://gist.github.com/albertbori/1798d88a93175b9da00b

If you have any issues, search the comments for the error message you encounter. For example, I got the Path had bad ownership/permissions error, but the solution is posted in the comments.

2
  • I would love to keep wi-fi on, because it provides integration with the iPhone copy/pasting, calls and messages and so on. This was working for me just fine until few days ago when it started. Even if I connect the ethernet first, it will stay default for some time, and then at some point it will switch back to wi-fi default. I am wondering what causes this switch to happen (can be some instability in the wired connection), but I doubt. Seems like some wrongly configured service that switch the order when it is not needed.
    – Valentin
    Jun 18, 2021 at 12:55
  • Are you still on Mojave? This could be a new issue in a more recent version! How exactly do you visually observe what is the current default and that it has switched?
    – PJSimon
    Jun 19, 2021 at 14:35
1

Make sure you've changed the "set service order" within the "gear" submenu:

enter image description here

2
  • 3
    I've already done this - Thunderbolt Ethernet Bridge is on top, Wifi at the bottom :-/
    – Jannick
    Jan 29, 2019 at 12:02
  • If you've changed the service order, maybe you forgot to click Apply for it to work?? Jul 12, 2023 at 7:07
0

In addition to what others have suggested, in System Preferences -> Sharing, also ensure that you have Internet Sharing disabled.

enter image description here

2
  • Can you explain why Internet Sharing would have any bearing on the effective service order? Mar 1, 2023 at 15:12
  • Because when you share your Ethernet connection over WiFi, it will ignore the service order if you prefer WiFi over Ethernet for example Mar 1, 2023 at 20:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .