0

Machine: MacBook Pro late 2013 OS: Mojave 10.14.1

Disk Utility reported several problems with my HDD, so I ran it in recovery mode, and when more problems were left, I ran fsck in single user mode.

The only problem that persisted was this:

warning: inode_val: object (oid 0x202797435): invalid bsd_flags (0x184)

From my research, this has to do with permissions. So I converted 202797435 to decimal and ran this terminal command to locate the file:

sudo find / -inum 8631448629

Which pointed me to this file:

/private/var/folders/8y/3pg_4v8n6m3bf4d11ln3z32c0000gn/T/fr.madrau.switchresx.app-559924946001.conf

I'm not sure how to proceed though, I don't know if it's safe to simply delete. It would appear so as fr.madrau.switchresx.app implies this is a config file for the app SwitchResX, but trying to move this file to Desktop was met with a permission denied error (I'm not sure this is part of MacOS protections, or the actual permission problem).

So...what's the best way to proceed from here?

  • guessing here but I would think running the latest combo update might update and fix that file. Failing that reinstalling the OS is probably the simplest and safest way to proceed. Unless you have a similar machine you can copy the file from. – Steve Chambers Jan 28 '19 at 0:19
1

After further research I found out it's safe to delete some files in private/var/folders (please do your own research), so I cded to the folder and deleted the file via Terminal:

sudo rm fr.madrau.switchresx.app-559924946001.conf

Disk utility reports are clean. If my SwitchResX settings are messed up I can always re-install it or re-configure.

  • Best choice of action. – IconDaemon Jan 28 '19 at 1:07

You must log in to answer this question.

Not the answer you're looking for?Browse other questions tagged .