I'm experiencing a vexing bug with Photo Stream (that at least some others seem to share), in which about 10% of the photos I take on my iOS devices just don't show up in the stream. I understand that I can manually import the missing photos (e.g. using Image Capture, Aperture or iPhoto) and then manually add them to my photo library, including to my Photo Stream (e.g., using Aperture). But this process is tedious and, of course, error prone: I need to periodically go through all the photos I've taken with each of my iOS devices and manually identify which photos haven't made it into the Photo Stream.

Is there a way to force a re-upload of all photos in an iOS device's Camera Roll to Photo Stream?

I've tried turning Photo Stream off and back on again on the affected iOS devices, but the missing photos remain missing.

  • I'd also be curious whether others here have experienced this bug. It's subtle and can go unnoticed (especially if you assume that Photo Stream "just works"), but pretty much renders the feature useless.
    – orome
    Dec 29, 2011 at 18:30

1 Answer 1


Directly no.

You can go the indirect route. Get all the photos to a computer, clear the photo stream manually, then enroll the computer into Photo Stream to inject the photos back into the stream in whatever order you prefer.

At that point, you can re-attach the iOS devices to the stream.

You might want to poke at the iOS side (restore or otherwise isolate the issue as it might be a software or network issue there - I've tried to break photo stream with bad network connections - lots of photos taken when offline or switching network from WiFi to 3G and back while taking pictures and it seems pretty robust to me and unbreakable when the software is working properly)

  • I've gone through Apple Support's suggestions of what to do several times, including full deletion and re-creation of my iCloud account on all affected devices and machines, as well as a complete rebuild of my (Aperture) library; but the problem persists.
    – orome
    Dec 29, 2011 at 18:53
  • Good - you've ruled out some things and can focus on others - the recreation of the account seems unlikely unless other cloud data is messed up - this is likely just in the photo stream tracking data. I'd detach all devices from the Photo Stream and set up a new account with just iPhoto and see if the stream works better on a new account - iPhoto and only one device. You'll quickly get to the problem being on one iOS device or just a bug on the server side that you don't directly control or get a handle on other than having the issue repeatable and escalated to engineering.
    – bmike
    Dec 29, 2011 at 21:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .