1

I have an issue getting the discrete graphics card to activate. The About This Mac screen shows only the Intel Iris Pro active.

I've checked that Automated Graphics Switching is enabled in the Energy Saver system preferences. gfxCardStatus shows Intel as active even when I select the Discrete Only option.

I've tried closing any open applications in case something was using the graphics but I'm still unable to activate the discrete graphics.

Does anyone know if there's a command I can run to check if a process might currently be using the integrated graphics? Is there any other way I can try to get the discrete graphics enabled?

Thanks in advance!

Macbook Pro 11,3 MacOS 10.10.5

  • Try disabling gfx. You can view which graphics you are using through either "system information" or through "Activity monitor." Open Photos and your GPU will be enabled. Check system information after photos is open since it doesn't update live. Your GPU is only enabled when it needs to be - primarily due to power considerations. – njboot Jan 26 at 4:44
  • Thanks for the reply. I tried that as well as a few other things that require high performance graphics but the discrete GPU still didn't activate. – Scottmeup Jan 26 at 11:51
  • Download and run etrecheck and reply with the output using a pastebin link. It’s free software that’s safe and reliable and is used to troubleshoot issues on forums like this while anonymize get all personal info. – njboot Jan 26 at 17:03
1

To know exactly what process is using the discrete card, look at the activity monitor energy tab "Requires High Perf GPU" column https://support.apple.com/en-gb/HT202053

To check what display devices are on your system entering the following in the terminal should work

system_profiler SPDisplaysDataType

As mentioned in a similar question https://apple.stackexchange.com/a/74881/39577

  • It's actually the low performance GPU that's stuck as active. – Scottmeup Jan 26 at 11:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .