1

I just got a new iPhone and decided to start fresh and not restore it from an old backup (old one is cluttered with tons of apps I don't use anymore).

Everything is working just fine except from iMessage. On my old phone, I've got settings -> icloud -> messages enabled. When I check iPhone storage on my old device, I can see that messages takes up 1.7GB.

When I first enabled the same Messages switch on my new device I did get a progress bar saying 'Downloading Messages from iCloud'. I waited for maybe 15 minutes but it seemed that not much happened and stupid me did go to the settings -> icloud -> messages and disabled it. My thought was to then turn it back on again too see if it somehow got stucked and this maneuver would fix the problem.

At this time, while disabling it, I got a message telling me 'Messages have not been fully downloaded, tap Disable and Download Messages'. I'm not even sure what this means but I did disable it. After a while I enabled it again but at this time, nothing more happens regarding Messages.

When I enter Messages I can see that some of my old messages have been transfered to my new phone but not all. If I check storage on my new phone I can see that Messages is taking up 858K of storage so something seems to have gone wrong (compared to the Messages storage on my old phone).

I have tried to enable/disable icloud Message sync a number of times but nothing happens. It seems to have lost it's connection to the stored iCloud messages. If I login to iCloud from a browser I can see that Messages takes up a whopping 4.4GB! Not sure why the iCloud storage is so large compared to my old phone Message storage.

Anyway, my question is, how can i resume the transfering of my old iMessages to my newly setup iPhone?

I've also tried to logout, settings -> Apple-ID -> logout, and then logged back in again but no luck.

| improve this question | | | | |
  • Welcome to Ask Different. It can take 24 hours to download all your messages to your new iPhone. Just be sure it's signed-in with your iCloud account, connected to wifi, and connected to power. Usually overnight is good. You have to stay signed-in to your iCloud account the entire time. Don't enable/disable it or you'll mess-up the downloading. – fsb Jan 25 '19 at 22:05
  • All the messages are back again :) Strange, I had this problem for maybe a week. Only some messages were synced and nothing more happened. Maybe it was me signing out/in with my Apple ID the other day that solved it. – Steffo Jan 27 '19 at 20:29
  • Signing in and out probably delayed the syncing. Remember, syncing for iCloud is not real-time so you have to wait for the sync to run. I'm glad it it worked for you. Please add your findings as an answer and accept it. This could help others who have a similar problem. – fsb Jan 28 '19 at 3:13
1

I guess it was me signing in and out of my Apple ID from my iPhone and waiting over night that solved it.

I had the problem for maybe a week. No syncing was taking place but after I (amongst other things) did the above, my messages are back.

| improve this answer | | | | |
0

I had the same problem but everything I tried above didn't work. I called Apple support and they had me upgrade my MacBook operating system to macOS Mojave.

After upgrading open Messages on your MacBook. Goto Preferences > iMessage > Settings. Check the box "Enable Messages in iCloud" and then click "Sync Now". Make sure that your keychain is active on both the MacBook and iphone. The sync took more than 12 hours and I had to keep syncing a few times to make sure it was complete. I then left my iphone plugged in overnight with wifi and all my old messages appeared.

| improve this answer | | | | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .