1

I attempted to use the command:

sudo rsync -vaE --progress /Volumes/1-mate /Volumes/Hired-Hand

.. to move the contents of one connected drive to another. This was going great until my boot drive filled all the way up (150mb free now).

The problem is that I mistyped the name of the destination.. should have been "HiredHand" NOT "Hired-Hand".

I am clueless where the copied files were placed and need to delete them so that I can use my computer again. Please help!

I am using macOS. Cannot locate any threads anywhere that deal with this issue.. other than someone 3 years ago on stack exchange saying "they found the files" and all is well now for them.

Thank you.

  • Aren‘t they in /Volumes/Hired-Hand? – nohillside Jan 23 at 8:52
  • So the problem is that I don't know where rsync created this volume.. somewhere on my main drive. I cannot find a .hired-hand or anything of the sort anywhere. I solved the main problem, only didn't learn much from it all.. I tried cd /Volumes/Hired-Hand and terminal indeed found it.. somewhere. From there, I used the command to list what's in it.. it showed the source disk name as a directory. I used sudo rm -R <directory name> and it deleted the contents and cleared up my space. the "volume" Hired-Hand is somewhere on my root directory unbeknownst to me.. as it isn't and was never physical. – B Rob Jan 23 at 8:58
  • 1
    Hired-Hand is just a directory, not a volume. If you removed all its content already you can use rmdir to remove it. – nohillside Jan 23 at 9:10
  • Thank you both for your input. ls -l /Volumes lists it as a Volume under "root" and "wheel" just the same as my OS HDD. The command "Mount" shows all my physical drives, just none with this name. At this point, its just a bit of a cleanliness thing.. don't want to see it as a volume forever, but since my space is back, there are worse things for a noob to have to deal with. Thank you for the very fast advice, nonetheless. – B Rob Jan 23 at 9:16
  • 1
    Hired-Hand is not a volume, it's "just" a directory. Creating a directory in /Volumes doesn't magically create volumes :-) – nohillside Jan 23 at 9:25
2

There is nothing inherently magically going on within /Volumes. So if you use rsync or something else to copy data into that folder, it will just do as told. If there is no folder with the target name already it will just create a new one on your main drive.

So

sudo rm -rf /Volumes/Hired-Hand

should remove the files/folders created by rsync. Just make sure you get the name right (and maybe eject the HiredHand drive first).

  • Thank you for this clarification and for all the collective activity shared here on my plight! Problem solved. For anyone else who might have the same questions as I did here, adding --inplace to the above command in the question, allows me to use rsync to move files without copying them to my OS HDD first, and thereby eliminate using space I don't have in this process. – B Rob Jan 23 at 9:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .