1

I usually leave my computer, and let it go to sleep after 15 minutes.

My external screen is showing a blue screen saying "HDMI no signal" every other minute while my MacBook is asleep, and the screen lasts for a few seconds. If I unplug the external screen, the message appears for a longer period of time. It did not happen with other computers (I have tested with a MacBook Air and a Windows Surface PC). The built-in screen is turned off and does not blink in any way.

enter image description here

Setup: I have a MacBook (Retina, 12-inch, 2017) running MacOS Mojave (10.14.1). I have a USB-C Digital AV Multiport Adapter, to which my external monitor (ASUS VS248H) is connected using a HDMI cable.

Question: Is there any way to avoid screen blinking (except for turning the screen off when I leave it)? I.e. sending the correct signal to the external screen, so it does not think it is disconnected.

  • Some screens have adjustable timeouts in their settings. I, however, don't do that. An LCD display comes on instantly, so I just turn it off, simple, easy and quick. – Steve Chambers Jan 22 at 13:26
  • @SteveChambers: Mine didn't have the setting either. But for me, the issue is with remembering to turn the screen off, not on (all other monitors stay turned off when the computer is asleep). I am hoping it is configurable. – Kristian Jan 22 at 15:47
2

The Apple Digital AV Multiport Adapter is a passive converter meaning that it's just "rearranging" the pin outs from the DisplayPort signal to the HDMI signal - basically, the monitor is detecting voltage, but there's no data being sent.

I expand on this more in this answer to a similar question.

Instead, you should be using either of the following with your monitor which supports DVI and HDMI:

  • Type C DisplayPort to DVI adapter (active is "better", but passive is OK here since DVI and DisplayPort are similar signals.
  • Tyep C DisplayPort to HDMI active adapter.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .