63

How can I hide username and computer in terminal command prompt?

In Terminal it says

Last login: Mon Jan 13 00:00:14 on ttys000
Whatever:~ UserName$ 

Is it possible to show just the current folder and $ sign?

  • 1
    What do you mean by show current folder? The current folder is already shown after the :. BTW: I've changed the computer name in System Preferences -> Sharing to MBP. Now my login prompt is very short: mbp:~ matt$ – gentmatt Dec 29 '11 at 7:27
92

Change your prompt in your ~/.bashrc file. The example you asked for would be:

export PS1="\W \$"

It would result in the current folder you're in being shown plus a $ for the regular prompt and a # if you're root. Check out this guide for more examples of what you could show in your prompt.

Edit:

As per one of the comments below, you might need to source your ~/.bashrc from your ~/.bash_profile or even put this code in your ~/.bash_profile instead. You can read this article for a better explanation on which file to use.

  • I have two questions since I have not that much experience working in the terminal :). 1) Why do you write ~/.bashrc? I found this file located at /private/bashrc. 2) I did not manage to edit the file because it is locked. I've tried changing permissions without success. – gentmatt Dec 29 '11 at 7:18
  • 2
    /etc/bashrc is the global file for all users, ~/.bashrcis your own. Definitions in your own overwrite whatever is defined in /etc/bashrc. – nohillside Dec 29 '11 at 7:37
  • 1
    bashrc files are your bash resource files. Where you can customize the prompt, set aliases, export variables. Things of that nature. Like patrix said, the /etc/bashrc and the /private/bashrc files have system-wide resources. So somewhere in the /etc/bashrc is an export PS1 and if you edit your own bashrc file which is located at ~/.bashrc and export your own PS1 then on your account the command prompt will be different. If you want it changed for all users you have to edit the /etc/bashrc with a sudo command. – CaldwellYSR Dec 29 '11 at 17:28
  • 2
    for anyone still looking at this answer.. you may need to put it in ~/.bash_profile Then run "source ~/.bash_profile" or just open a new terminal. – Chris Aug 9 '14 at 0:38
  • export PS1='[\h:\W \u \$ ' to undo this operation if you want to later. – Boldijar Paul Jan 22 '18 at 7:46
16
echo "export PS1='$ '" >> ~/.bash_profile
. ~/.bash_profile

This will leave just $ as a prompt. If you want to restore the old prompt, you will need to edit .bash_profile to remove that "export ..." line.

14

I had a similar issue with this but did not get it working at first.

This may of been because I wasn't sudo but either way this works just as well.

  1. Open the preferences in the terminal (top right)
  2. Then go into the shell tab
  3. Then copy/paste the command export PS1="\W \$"; clear;
  4. Then restart the terminal and should work

enter image description here

  • Best simple :). – Huynh Inc Jan 27 '16 at 2:44
  • This is the best for temporary solutions. – Tarik Mar 20 '17 at 6:38
11

Check out this tutorial on how to change your bash prompt. A very short version (only username and no current path): PS1="\u$ "

Result: myusername$ cat something.log

  • It works, now the problem is it will not save the new bash prompt. It will show the old one after i shut down my mac. Why? – DzulFriday May 15 '12 at 2:07
  • 2
    Did you put the variable in the following file: /Users/<yourusername>/.bash_profile? – timbooo May 15 '12 at 15:34
2

Edit ~/.bash_profile to save your changes to prompt.

sudo nano ~/.bash_profile

At the end, add your changes.

# Change prompt
export PS1="\W \$ "

Exit, save changes. Hit enter to confirm the file name. Run source to see the change.

source ~/.bash_profile
  • Thanks, this worked nicely for me, using OSX 10.12 Sierra. – Edvard Haugland Sep 9 '17 at 11:39
  • Why use sudo? – dan Feb 19 at 12:21
0

Create/Edit your .bash_profile file or your root:

sudo vim ~/.bash_profile

and add this line

export PS1="\W$: "

The space will give you some breathing space in command prompt. After this modification your command prompt will looks like this:

~$: 
0

Set DEFAULT_USER in ~/.zshrc file to your regular username. You can get your exact username value by executing whoami in the terminal. Something like this:

export DEFAULT_USER=username
0

export PS1="[\033[01;32m]\W \$ [\033[00m]"

\W will give you the current folder (\w to include the path too). The brackets set the color codes. So this puts the current folder in green, and then resets the color to white after the prompt.

-3

Mine is: PS1="\W[\033[32m]\$(parse_git_branch)[\033[00m] $ "

  • We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed. – Tetsujin Sep 30 '16 at 16:15
  • Delete, i don't care i was only trying to help! – Carlos Oct 1 '16 at 17:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .