1

I tried resetting the SMC as I saw this repeatedly being suggested as the solution but this did nothing. Computer charges fine but any light on the cord is out. Any other suggestions? Am I damaging the computer using it with the light out?

  • Firstly, welcome to Ask Different! :) I hope you come to find this site has a lot to offer! In case you haven't already, it's worth taking the time to read the tour. In the meantime, can I ask how you reset the SMC? The process can differ for different models of Mac. As for damaging the Mac because the light is out, this should pose no problems for your MBA - especially if everything else seems to be working normally. – Monomeeth Jan 19 at 21:29
  • Have you checked the connection - the magsafe will charge with a "poor" connection caused by a small bit of fluff etc and not show the light. I find making the connection a couple of times or blowing on both parts helps... Well, works on mine and have 2 with me at the moment... – Solar Mike Jan 20 at 8:00
  • Monomeeth. Thank you for answering. The first thing I did was pull the two pieces apart and check for crud. As far as resetting the SMC - I read the directions on how to do that in several places, directions matched so followed them. Seems to me (form memory) held down, at the same time option,control, shift and power button, released then hit the power button again. This is a mid 2013 macair 13" and everything else is working normally except for screen issues that I have been to apple several times about and get differing answers about what is wrong. – Annon1234 Jan 21 at 4:39
  • Solar Mike thank you for the suggestion. I have more than one charging cord and the light comes on with the other one. I did check the one that the light doesn't work. It has an adapter so that the older style cord fits it. Everything seemed clean and charging times seem normal. – Annon1234 Jan 21 at 4:43

You must log in to answer this question.

Browse other questions tagged .