If I run a simple osascript from the command line:

osascript -e 'tell app "Safari" to activate'

I get hundreds of this error:

2019-01-19 13:07:31.224 osascript[3908:9313907] Error loading /Library/QuickTime/EyeTV MPEG Support.component/Contents/MacOS/EyeTV MPEG Support: dlopen(/Library/QuickTime/EyeTV MPEG Support.component/Contents/MacOS/EyeTV MPEG Support, 0x0106): code signature in (/Library/QuickTime/EyeTV MPEG Support.component/Contents/MacOS/EyeTV MPEG Support) not valid for use in process: mapping process is a platform binary, but mapped file is not

I have to wait for the errors to finish running before the script actually runs, which is annoying.

I tried using codesign to fix the issue:

codesign --architecture x86_64 -f -s "My Cert" 'EyeTV MPEG Support'

But it didn't help. I believe the error is caused by Mojave's security policy.

One way to fix this is to remove the the QuickTime component from this folder. But I'm hoping there is a better fix as the EyeTV app requires this component to run.



I move it out into a new folder I created called ~/BadLibraries. EyeTV still Works for me.

|improve this answer|||||
  • Wow, you are right! Maybe eyetv was just being hinky when I first tried it. – StevieD Jan 21 '19 at 15:02
  • actually, it's just re-installing the component when I open EyeTV. – StevieD Jan 21 '19 at 15:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .