1

I use a HD with a caddy adapter for saving some files. macOS attributes a unique identifier for each external drive connected. But I needed to swap my adapter for the same disk, and now it's not mounting because the identifier is not unique:

error USBMSC Identifier (non-unique) on console.

In the past, for the same problem, I deleted the drive label/id/something - I don't remember now - on a folder, and my drive would mount normally again when I reconnected it.

Does anyone know what it is I would have done on the folder to correct these IDs in the past?

Additional Info:

  • The disk is recognized by macOS internet recovery > Disk Utility
  • If I put the drive and try to open Disk Utility on currently installed macOS, it hangs and doesn't load.
  • the disk is showed at command diskutil list, but fails to mount using diskutil mountDisk -t Apple_HFS /dev/disk2 /Volumes/Home
  • If I change the drive name on Internet Recovery and connect it to the macOS installed, it's recognized on the first time, but not on a second.

It's purely a mistake with unique id, and I know it could be resolved by deleting this id or a label, but I wasn't able to find the article with the solution I used previously. I cannot erase the disk because it has some important files, and the drive is working normally. The problem is in the system.

  • Welcome to Ask Different! :) I hope you come to find this site has a lot to offer! In case you haven't already, it's worth taking the time to read the tour. All the best! – Monomeeth Jan 19 at 21:23
1

I finally remembered: the disk is mounted on /dev, but in this case, not on /Volumes. In macOS High Sierra, I:

  • excluded both disk and disk partitions from the /dev folder using sudo rm -rf /dev/disk2 && sudo rm -rf /dev/disk2s1,
  • disconnected and reconnected the disk,
  • deleted the disk folder mounted at /Volumes,
  • rebooted the system and it was recognized.

But, it doesn't worked on Mojave.

Using the image on Internet Recovery, I renamed the disk label, which makes the disk being recognized by Mojave. But, as said, it only worked for the first time I connected the disk after renaming.

So, I repeated the renaming, copied my files and formatted it. For avoiding futures annoyances, I decided to use NTFS instead of APFS, because the files on this disk could be used as read-only by me on macOS, and, if I need, exchange files using a Windows virtual machine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .