0

So I have iMac 5k Late 2014 with macOS Mojave. I also have installed bootcamp Windows 10 although I'm not sure if this is relevant. For a while now I have been experiencing a peculiar issue with start up. If I power off computer and then power it back on, no loadable boot drive screen appears (image with crossed circle below). If I only restart computer, sometimes it works fine, it boots macOS, but sometimes the same error screen appears. If I restart from macOS to Windows, it works fine, same goes for Windows to Windows restart. If I restart from Windows to macOS, it doesn't work. If I power on to Windows it works just fine.

enter image description here

My workaround is to hold opt key while powering on so that the boot manager loads. There I can choose any OS and it always works.

The start up itself takes about a minute to even show the loading screen (image with Apple logo below), which is unusually long compared to loading time before the issue started. The progress bar goes to about 3/4 and then the no drive screen appears.

enter image description here

I should mention I have Fusion drive (that is 128 GB SSD and 1 TB HDD), formatted to APFS although this issue is recuring even since before the file system update.

Oh, and no formatting, clean install or anything like that worked, I tried it all. When I install OS X Yosemite, the issue perishes, however when I update to Mojave it comes back. I think the first OS update that did this was Sierra.

You must log in to answer this question.

Browse other questions tagged .