I am currently having issues with iMessage. I cannot text my friend for some reason (iPhone user as well). When I hold the iMessage to send it as a text, it says "Send as Email" instead. However, I can send texts to other people with iPhones as well. I have checked my "Send & Receive" and my number and email are checked. I have also tried deleting my friend's email on my contacts but no difference, only the email registers to my phone when that person tries to contact me via facetime, iMessage, etc.

On the other hand, my friend can be texted by other iPhone users except me. She can text me, but I cannot reply as a text message. On her "Send & Receive" there is no "check" on her phone number but rather a loading sign beside it that doesn't seem to go away.

  • What is in your contact for her?
    – mmmmmm
    Commented Jan 19, 2019 at 13:20
  • I'm getting the same issue! With only one contact. Everyone else I can send a text when I disable iMessage, but with one contact it will give me an error saying I need iMessage to send message. Have you tried deleting your entire conversation in messages with the contact in question? (I haven't yet, sentimental value I wanted to keep it but I will delete if I have to)
    – Sasha
    Commented Jan 27, 2019 at 16:28
  • Hi! My problem got resolved. What I did was delete the entire thread and send a message. My phone automatically made two threads, one for texts and one for iMessage. Out of nowhere they magically synced together after two days.
    – Adriel Lao
    Commented Feb 14, 2019 at 9:22

3 Answers 3


Create a new message from your iPhone and pick his phone number as the receiver (do not use the existing conversation). Then when you send him a message the option should become available.

The reason you cannot send your messages as text messages is because he probably messaged you with his email-address as the sender, not his phone number.

  • This didn't work :/
    – Adriel Lao
    Commented Feb 14, 2019 at 9:21

Try resetting your date and time settings. Go to Settings>General>Date & Time>Turn off 'Set Automatically' and then turn it back on. That worked for me.


I was having the same issue until I figured out if the conversation is an iMessage conversation with a persons iCloud address, the option to send as SMS will not show up. You will have to delete the conversation and start a fresh one with the contact’s phone number in order to get the “send as SMS” option.

To check - iMessage is blue, text message is green

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .