I know there is a similar question, but it seems that on-screen alerts are supposed to be built into the Notifications Settings and that using a third-party app should not be necessary. Even though I have alerts selected (the three options are none, banner, and alerts) in Settings > Notifications > Mail, they do not show up. Any thoughts on why?

  • 1
    Have you checked that the first option - Notification Centre is switched on? Jan 5, 2012 at 13:54

1 Answer 1


In addition to the Alert Style options which you mention setting, you also need to turn ON Notification Center for those alerts to appear in Notification Center, and also set View in Lock Screen to ON, to see them when your screen is locked.

Otherwise you will only see them when you are using the phone at the time that they come in, and if you already have Mail open, then they won't appear at all.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .