0

So I connected my mbp mid 2012 13" to my del p2213 monitor which has a native resolution of 1680x1050 and a aspect ratio of 16:10 but apparantly when I went to the display settings and pressed scaled while holding "alt/option" it only showed some resolutions up to 1920x1080 and only one of those resolutions are 16:10 which is 1280x800 (also it's my built in screen's native resolution)

So I tried to use Switchresx and was able to find a 1680x1050 scaled resolution but apparently when I clicked on it, it set the aspect ratio to what I assume 16:9 and it now has black borders on top and bottom and the image is also stretched and most of the text is quite unreadable.

The next thing I tried was to create a custom resolution via switchresx with the properties of this link. Unfortunately once I hit ok and clicked "Install Immediately" It flashed both of my screens as if the resolution changed but the custom res's status is just saying "Not Installed" and the resolution wasn't changed. I ended up trying this and it did not work. (Still not installed) Keep in mind System Integrity Protection is already disabled at this point.

I also tried closing the macbook's lid and plugging in a mouse and once I clicked on it, the monitor did end up working without the need of the built in display. But still no luck with the 1680x1050 resolution even with a switchresx custom res.

Anyone knows a way to fix this issue?

  • Have you tried making extending the displays (eg: so that they aren't mirrored)? – technogeek1995 Feb 20 at 15:41

You must log in to answer this question.

Browse other questions tagged .