1

The problem:

I recently got a 2018 15-inch MacBook Pro running MacOS 10.14.2 (Mojave). I'm running into a really long freeze when I bring it out of a long sleep (e.g. by opening the lid after keeping it in a bag overnight). Here are the symptoms:

  • The computer will wake up and display the login screen. However, the password textbox is grayed out and does not say "enter password" and the menu bar widgets (such as battery, wifi, and the clock) are not displayed.
  • Keyboard and trackpad are initially unresponsive for several minutes.
  • Usually, the touchbar is on and the fn key can change the mode, but none of the softkeys have any effect. Though, a few times the fn key has had no effect changing the touchbar mode during some part of the freeze.
  • Eventually the colorful spinning beachball cursor will appear, but the computer remains unresponsive. The beach ball will usually start frozen and not spinning, but start spinning a few minutes later.
  • After 5-10 total minutes of waiting, the computer becomes responsive, password textbox becomes active, menu bar widgets are shown, and I can finally unlock it.
  • Some of the time, the keyboard modifier keys get remapped to the defaults (I swap control and command because I also use Windows).
  • Once during a freeze, the system crashed and rebooted. The crash report listed the OS as Bridge OS 3.3 (16P3133) and the panic message was userspace panic: remoted connection watchdog expired, no updates from remoted monitoring thread in 75 seconds.

What I've tried:

  • Rebooting
  • Resetting the SMC (using both methods in the comment below)
  • Repeatedly hitting keys in frustration during the freezes
  • Resetting the PRAM
  • Reinstalling the OS (in a way that kept all my data and apps)
  • Reinstalling JAMF (apparently a newer version that's supposed to have fewer issues with Sierra)
  • Wiping the disk and reinstalling the OS
  • Getting the logic board and "touch id board" replaced at the Apple store under warranty, and reinstalled from a Time Machine backup. However, some people in this thread said their Bridge OS crashing issues were only resolved after several replacements.

None of these things have helped with the freezing problem.


System Information:

OS:

  • Mac OS Mojave 10.14.2 (and 10.14.3)

Hardware:

  • Model: MacBook Pro (15-inch, 2018, MacBookPro15,1)
  • Graphics: Intel UHD Graphics 630 1536 MB, as well as an AMD Radeon Pro 560X 4096MB that seems to be rarely active
  • Memory: 16 GB

Major Peripherals:

Other major software:

  • Parallels Desktop 14 for Mac Business Edition 14.1.0 (45387)
  • Jamf
  • Docker Desktop 2.0.0.2 (30215)
  • Office 2016/Office 365
  • Time Machine backup configured, using a HD connected to the docking station.
  • Did you try both ways to reset the SMC? – user3052786 Jan 17 at 22:57
  • @user3052786 I tried one way, holding down some keys at startup. I didn't know there were two ways. Can you tell me both ways so I can try the other? – Kaypro II Jan 18 at 23:50
  • 1
    On portables with T2, holding power for a long time while system is off is 1, right shift + left option + left control for 7 seconds and then adding in the power button for additional 7 seconds is the other. – user3052786 Jan 19 at 8:28
  • I tried that and it didn't work. I've also tried resetting the PRAM and reinstalling the OS based on the recommendations of my comany's IT department. That didn't help either. – Kaypro II Jan 24 at 16:05
  • The problem persisted after a erase and install of macOS? If it did before you put any of your stuff back I would start suspecting hardware issues. – user3052786 Jan 24 at 22:44
1

I managed to solve my issue by downgrading from Mojave to High Sierra (using this procedure). It was very difficult to do, and I was very unsure if Apple would let me downgrade, but once I did it the freezing issue went away.

I've had coworkers inform me that they've recently upgraded to Mojave with no problems, so whatever issue I encountered may be fixed. However, due to all the pain I've gone through with this, I'm sticking with High Sierra.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .