0

In the light of unbricking my 2011 MBPro due to the known dGPU failure, I am following LangLangC's (great!) response/guide in GPU problem - Boot Hangs on Grey Screen; combined with some other threads I found regarding the extra challenges that come with High Sierra.

I was able to disable SIP, so that works (checked via csrutil status: S.I.P. status: disabled (Apple Internal)).

However when I try /sbin/mount -uw / it responds "disk2s1: device is write locked", so impossible to mkdir ... to start moving the kext.

Most Q's and A's I found about this issue are about getting SIP disabled, which apparently worked for me? Where is the mistake and how can it be solved?

EDIT: Being in single-user-mode my command line started with sh-3.2, now it is localhost: root# and saying HID: legacy shim 2. Which after Googling happens most with Hackintoshs, strange (even after resetting PRAM again). Any help or thought is appreciated.

1

I can say that the problem was indeed with SIP.

status: disabled (Apple Internal) should apparently have been status: disabled without (Apple Internal).

Unfortunately, I only got so far by retrying several times and mixing up the order of some steps up to step 7, and can not with certainty say what has fixed it.

Now moving on to Part 2.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .