3

I am unable to block a contact on my mac's iMessage app (Mac OS 10.14.2).

I go to preferences > imessage > blocked > + , and then a drop down of my contacts appears. I select the name from the list but then the list just disappears and nothing is added to the blocked list. (And yes they are still able to contact me).

Any ideas as to what I'm doing wrong?

iMessage window

  • 1
    I'm sure we had another question like this recently, but I can't find it right now. I can't get this to work either, so unless someone has a fix/workaround I'll log it as a bug in 10.14.3 beta4 – Tetsujin Jan 17 at 7:33
  • How do I go about logging it as a bug? I'm really at a loss with it as I need to block this person, so I've had to stop using imessage on my mac as a result. – advert2013 Jan 24 at 13:50
  • 1
    Are you using Messages in iCloud? Have you tried blocking a contact on your iPhone? I tried the same steps you tried and got the same results. Contacts/Calls that I had blocked on my iPhone do display correctly on Messages on my Mac. Can you try that? – fsb Jan 27 at 14:27
2

As a workaround, you can add a phone number as blocked in the FaceTime app on macOS, and it will also register as blocked in Messages (at least it worked for me, and I had the same issue on 10.14.3).

2
+50

I think the issue here is your contact syncing service trying to override what you're trying to do.

They should be using one account/service like Google or iCloud or Yahoo and not all together as you get this round robin effect of one service overriding what you are trying to do.

(Source)

To stop this you will need to stop syncing more than one account on your Mac.

To stop Yahoo sync:

How do I stop Yahoo Sync?

To stop Google sync see here.

To stop iCloud sync:

Choose Apple menu > System Preferences.

Click iCloud.

Uncheck contacts.

Another issue:

Another issue is the phone can be updated from other devices as they are set to say iCloud but the iPhone is set to "Keep on Phone".

If the issue persists it is probably a bug, you can report it here.

  • Thanks for your answer. Unfortunately I only use iCloud for my contacts. I tried resetting the sync, by checking and unchecking it, but the same problem remains. – advert2013 Jan 26 at 19:17
  • 1
    @advert2013 it could be a bug and you should report it – user310476 Jan 26 at 19:26
  • Thanks for your help. I've submitted a bug report, hopefully they fix it. – advert2013 Jan 26 at 23:32
  • 1
    Doesn't work for me either, including on 10.14.3. @advert2013 I'd recommend answering your own question here — "its a real bug" type thing — so it can get upvoted. – Geoff Nixon Jan 28 at 1:20
2

This is a known bug with Mac OS 10.14.2 (and Mac OS 10.14.3 beta) and there is currently no solution. I've reported it to apple.

  • 1
    thanks for answering your quesiton. While my answer doesn't provide a solution and might no get accepted/bounty awarded i am going to leave it here in case it helps other users – user310476 Jan 30 at 19:16
  • Thanks, yeah I would accept the answer, but it doesn't solve the issue my question refers to. But hopefully it will help others as you say. – advert2013 Jan 30 at 20:32
  • i hope so as well, as i spent time on it it would be gratefully appreciated if you award the bounty by clicking the +50 icon, thanks – user310476 Jan 30 at 20:35
  • Sure yeah, done. Since it's an actual bug no one else can give a better answer I guess! – advert2013 Jan 30 at 23:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .