0

enter image description here

I get a random popup from an unknown program asking for my password. What is this? how do I stop it. It doesn't show in the doc. Macs don't even have iMessage so this makes zero sense. I don't have an iphone and the "Allow Handoff between this Mac and your iCloud devices is off." I have no accounts in Messages or Internet Accounts. I don't have iCloud configured at all.

I tried rm -rf on Messenger.app, but it's a protected folder.

  • "Macs don't even have iMessage"... yes they do. App is called Messages. Nothing to do with 'Messenger' which is a Facebook term. – Tetsujin Jan 16 at 19:59
  • @Tetsujin that's what iMeant. fixed – Ray Foss Jan 17 at 14:52
2

The only way to get rid of it is to disassociate your AppleID from Messages. Merely disabling won't do it. There is no graphical interface for completely removing the AppleID from messages this. You either have to create a new local computer account, or:

In High Sierra,

cd ~Library/Preferences/ByHost/

Now list the files with "idstatuscache" with the following command:

ls *idstatuscache*

delete it with:

rm com.apple.identityservices.idstatuscache.your unique string.plist

Now restart. You should no longer get that popup on boot. Now I get Facetime ones. I also deleted my chat history, I don't believe that helped.

To deal with the Facetime ones that will follow: http://osxdaily.com/2015/03/04/fix-mac-asking-icloud-password-randomly/

Sources:

https://www.iphonefaq.org/archives/975913

How do I remove an iMessage account from OS X (Yosemite) Messages app?

0

If you don’t want to use iMessage, here is how you disable the Account.

  • Open the “Messages” App in your Applications folder
  • Open Preferences
  • Check if there is an iMessage Account configured, turn it off if you don’t need it

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .