I have a problem with the wifi on my MacBook, Late 2006 model.

The problem is that I only get a wifi connection if my computer is within 1m of the router. I have tried this with my Time Capsule and with my D-Link router. If I am on the couch with it (2-3m from the MacBook) it does find the network but I instantly get the error message:

Connection reached a max time limit

I ordered an Airport card from PowerBookMedic.com which came today, and I exchanged the one that was in the MacBook; However, I still have the same problem. The wifi antenna cable seem to have no damage in the machine, and go as they should into the screen frame. However, I am unable to see them in the wrench at the bottom of the screen, and would like to skip opening the screen just to see the antenna.

The MacBook's HD came from another, slightly more powerful A1181 MacBook which I just put into this machine and booted. The other machine had no problems with the wifi; however, I sold it a few weeks ago.

My other devices at home have no problems with my wifi. These devices include a Mac mini, MacBook Pro 5,2, HP Photosmart, iPad, 3 iPhone 4's and an iPhone 3GS.

Also the bluetooth seems to work fine. Any ideas on what can be the problem? I've googled it a bit and don't seem to be the only one.

My MacBook is running 10.7.2 with all the latest updates installed.

3 Answers 3


If you put the HD from another machine into this mac it may have kexts for the wrong model installed. Erase the drive and reinstall Lion. During the install process it should download the specific components needed for that exact model.


Has it worked since you swapped the hard drives over? It might be remembering something wrong in the network profile - go to Network Settings > Advanced and select your network, then click the '-' on the bottom left - apply, restart AirPort and try connecting afresh. This always helps me when I have connection issues.

  • No, it has never worked since I swapped drives. I bought the D-link router just last week and installed it exchanging my Netgear... so it can't remember that. Dec 28, 2011 at 21:15
  • Hmm. Also worth checking Network > Advanced > TC/IP and ensuring that it is set to obtain from network - that 'could' prompt an error, I guess? Dec 28, 2011 at 21:17
  • Its set to DHCP, as it should. Already checked that as well :( Dec 28, 2011 at 21:36

In the end it turned out to be a broken wifi antenna... I repaired the error (pretty anoying to repair actually, and take a s*it load of time... and then sold it fully working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .