I have an ADATA HD710 1TB external hard drive which I use mostly in my Mac Mini 2011 and I have created two separate partitions for my drive.

One of the partitions has APFS (Apple File System) format and the other has MS-DOS FAT (FAT32) format. I use the second one for Windows 10 that is installed on my computer using Bootcamp. As it's not possible to view files of the drive which is formatted in APSF in Windows I use that FAT32 partition to move some files from my main drive to that and view them in Windows.

Yesterday I plugged my external drive in to Windows 10 and after copying some files I just ejected it. Today when I tried to access my files in macOS I realized that my Hard drive's format is changed to FAT16 and none of the two partitions which I had created are displayed.

enter image description here

I tried repairing my drive using the Disk Utility's First Aid feature but it didn't work. I also tried repairing it via Terminal using diskutil repairDisk command and the result was the same as Disk Utility. Finally, I tried repairing it in Windows (using diskpart commands) and I was unsuccessful again.

How can I fix this issue?

Please notice that I really need the information inside my main partition of the drive (The FAT32 partition is not that important for me). Otherwise, I know that if I erase the whole drive, I can use it again.

The exact error message that I get when I connect my external drive to macOS is:

The disk you inserted was not readable by this computer.

  • Have you tried plugging it into Windows again to see if you can access your files there?
    – jksoegaard
    Jan 14, 2019 at 13:21
  • @jksoegaard Of Course, It is not accessible in Windows, too. Jan 14, 2019 at 13:25
  • Sounds like you formatted the drive? Is that possible?
    – jksoegaard
    Jan 14, 2019 at 17:25
  • @jksoegaard No it ain't possible. I never formatted the drive. somehow the drive changed to a raw drive but I don't know why? All I know is that the information inside it is really crucial for me. Jan 14, 2019 at 18:47
  • It's hard for me to judge whether you could have (unknowingly) done something to remove the partition table from the drive. If the information is crucial for you, it is very important to stop doing anything (at all) to the drive. For all you know, it could be a failing drive. The first thing to do is to read out a full bit-for-bit copy of everything that is on the drive. Then only work on copies of that image file instead of on the original drive.
    – jksoegaard
    Jan 14, 2019 at 21:23

2 Answers 2


It seems somehow the partition table (and possibly more) was corrupted on your hard drive, as you indicate that the drive is not readable anymore in macOS or from Windows.

The next step is to stop touching the drive at all before you have made a bit-for-bit image copy of everything on it to secondary storage. After that you can work on copies of that image in order to try to rescue your data.

It might be that you accidentally overwrote the partition table unknowingly. Then data recovery is probably fairly easy. It might be that your drive is starting to fail and various errors pop up sporadically - this is usually much, much harder to recover data from.

In order to create a bit-for-bit copy of the drive, you'll need to find the disk number from Disk Utility. In your screenshot it is currently listed as "disk2", please ensure that you double check this before proceeding.

When you have the disk number, open Terminal and run the following command:

dd if=/dev/rdisk2 of=my_image_file.img bs=512 conv=noerror,sync

The command probably takes a long while to complete - creating a new file named "my_image_file.img" containing a complete copy of your drive. Make sure that you have space enough to store the file. If you haven't got room on your internal drive, you can plug in another external drive and store the file there.

The "noerror" and "sync" options to dd makes sure that if there are drive read errors (i.e. the drive is actually physically failing) then dd will try to skip the errors, replacing those with bytes containing zeros. This won't get you the data back ofcourse, but it makes a lot easier to recover the rest of the data.

When you have the image copy, you can use any data extraction / data recovery software to work on the image to try to find your partitions, file systems, or even single files that you want to extract.

  • Thanks a lot, I'll try this and if it worked I'll accept your answer. Jan 15, 2019 at 8:22
  • Thanks for you answer again, I've created the image which recovery application you offer? Jan 18, 2019 at 17:10

As I was 100% sure that I hadn't formatted my hard drive, I tried several data recovery apps and one of them worked very well for me.

I had two partitions in my hard drive. One of them had APFS format and the other had FAT32 format. Unfortunately there were only a few recovery apps that had the capability of scanning raw data of APFS drives and among them M3 Data Recovery Professional Edition for Mac was the best. I paid something like 107.10 Euro but I think it was definitely worth it.

It recovered all lost files and then I copied them into a secondary hard drive as @jksoegaard suggested.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .