0

When I turn on iMac (iMac Intel 21.5" EMC 2428, Model A1311 / Mid 2011)

I get the chime and after some time, a blinking question mark inside a folder icon appears.

I have tried all combination keys on mac wireless keyboard and Windows USB Keyboard but nothing worked.

Then I replaced hard drive for brand new SSD but that didn't change anything.

What else I have tried:

1) All combination keys I could think of. On original mac wireless keyboard and Windows USB keyboard.

D, N, T, Option, Command + R, Option + Command + P + R, Shift, Command + S, Command + V

Whatever combination I use, doesn't make any impact on the boot process and a question mark appears after while.

2) I plug USB Stick with a bootable system and also System on CD but none of the combination keys worked. I'm unable to eject CD using the Eject button on the keyboard. I can only eject using the mouse while starting.

3) I have replaced batteries on the keyboard and when I turn on with side power button I can see a green LED briefly turn on. Caps lock LED doesn't work but I don't remember this working ever.

4) I have removed all but one RAM carrier.

I spent the last few days researching the problem but all point to faulty HDD which I already replaced. What could be a problem? Anything else I could try?

marked as duplicate by Allan, Ɱark Ƭ, fsb, IconDaemon, Glorfindel Jan 14 at 18:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • RE: all of those key combinations, Verbose Mode, Single User Mode and Recovery won't work because you need a functioning hard drive. Diagnostics won't work because that vintage iMac came with diagnostics on Disk 2 of the DVD set. Resetting the NVRAM would have no effect and network, netboot won't work unless you have a netboot server and target disk mode won't work unless you have another Mac that's connected to it. The problem is your drive - it needs to be replaced. – Allan Jan 14 at 13:51
  • It turns out that none of the combination keys worked because of faulty (original) iMac Bluetooth keyboard fault (detected in the system but all keys didn't work), also new USB PC keyboard didn't work despite working on PC. I've tried a second USB keyboard and that worked well. So hint to everyone: try different keyboards... – Solver Feb 28 at 16:22

Browse other questions tagged .