0

I found that the key combinations Ctrl-Shift-D/E/F somtimes are not working

I really do not know what caused this, but a few tests are as follows,

  • Restart the computer or logging out and back in is the only two ways I know to temporarily solve the problem, but the issue comes back after some period (no idea what triggered this);
  • The hardware is OK (I think). I used the Keyboard Viewer and can see that only these three combinations have problems. Specifically, I can see that when SHIFT and CTRL are pressed, pressing D,E,or F has no response. Others are fine, for example, CTRL+SHIFT+T works fine;
  • While on screen saver, the key combinations works fine while I experiment on the passwords I typed.

How can I resolve this?

PS: I recently updated to Mojave, but I recall that the issue happened once before the update. Also the model is MacBook Pro (Retina, 13-inch, Late 2013), and currently I'm not using an external keyboard. (I just tried plugging in another keyboard, still not working.)

  • Also: Do you have access to (another) external keyboard you could plug in/attach at a moment the problem occurs (this would help in figuring out whether it's a hardware or a software issue)? Can you fast-switch to an other user if the problem occurs (may need to create one beforehand) and see whether the problem occurs there as well? – nohillside Jan 13 at 14:10
  • @nohillside just added information on model and external keyboard. currently I do not have another account, but the combination works while I'm logging in. – davyjones Jan 13 at 14:21
  • Well, if it also doesn't work on the external keyboard it's most probably not a hardware issue. Any idea of some software you might have running which would capture those keystrokes? – nohillside Jan 13 at 14:21
  • Do the D/E/F keys work on their own? – Allan Jan 13 at 14:25
  • @nohillside, I cannot think of any software that affect those keystrokes, and I'm still trying to identify what I did to cause the issue. At first I encountered the issue while using emacs, but I have been using emacs for quite some time. The issue only occurs recently. – davyjones Jan 13 at 14:25
1

I just found out that the problem is caused by Sougou Pinyin, a Chinese input software, who recently updated itself with some features along with these new shortcut keys as shown below (pls excuse the Chinise interface) enter image description here (Obviously I missed the shift+cmd+E).

Now I have disabled them all.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .