2

I did a fresh install of fink 0.43.1 on a High Sierra system, then installed texlive and all of its prerequisites. That all works fine.

Then I try to add xemacs:

fink install xemacs

and I am met with this error:

Information about 10475 packages read in 1 seconds.
Can't resolve dependency "system-xfree86 (>= 3:2.7.112-3)" for package "xemacs-21.4.22-9" (no matching packages/versions
found)
Exiting with failure.

The fink list command indicates the latest available version of system-xfree86 is 2.7.86-3. How can I get around this?

  • Do you have Xquarts installed? – fd0 Jan 11 at 18:13
  • Yes, it is under /opt/X11, which I believe is the standard location (I am fairly new to X on OS X). – Eric Winter Jan 11 at 18:21
  • Where was x quartz installed from? – Mark Jan 12 at 15:06
  • Does fink know it's there, or did you install it from the separately-downloadable Xquartz? Having said that, it looks like your problem is simply that fink does not currently have a version of XFree86 that satisfies the dependency introduced by the Xemacs maintainer. I’d have to ask why you're trying to install an Emacs that's going to depend on X11 being running... not at all getting into why run GNU Emacs vs Xemacs, but the X11 dep would normally be a hard stop these days on a Mac. – Marc Wilson Jan 13 at 3:43
  • Haven't used fink for ages, but isn't there an Emacs which doesn't require X11? – nohillside Jan 14 at 12:06

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.