0

We are planning on using a Freenas installation to share the home directories of our users over SMB. In the test phase we noticed that everything works fine except that at the end of a file transfer (over the Finder or by downloading the file in the web browser, because it lands in the Downloads folder which is in the home directory,) the network freezes and it takes around 20 sec. until the transfer finishes. The same setup works fine when using a Mac Mini to share the home directories over SMB.

We already tried different SMB versions and the vfs modules fruit and catia are enabled. Sharing the home dirs over AFP on the Freenas machine works fine but since it is effectivly deprecated we do not plan on using it.

Samba Config on Freenas:

root@freenas[~]# testparm
Load smb config files from /usr/local/etc/smb4.conf
Processing section "[home]"
Loaded services file OK.
Server role: ROLE_DOMAIN_MEMBER

Press enter to see a dump of your service definitions

# Global parameters
[global]
    ads dns update = No
    bind interfaces only = Yes
    client ldap sasl wrapping = seal
    deadtime = 15
    disable spoolss = Yes
    dns proxy = No
    domain master = No
    dos charset = CP437
    hostname lookups = Yes
    interfaces = *********
    kernel change notify = No
    lm announce = Yes
    load printers = No
    local master = No
    logging = file
    map to guest = Bad User
    max log size = 51200
    max open files = 470666
    nsupdate command = /usr/local/bin/samba-nsupdate -g
    obey pam restrictions = Yes
    panic action = /usr/local/libexec/samba/samba-backtrace
    preferred master = No
    printcap name = /dev/null
    realm = *****.******.*****
    security = ADS
    server min protocol = SMB2_02
    server role = member server
    server string = FreeNAS Server
    template shell = /bin/sh
    winbind cache time = 7200
    winbind enum groups = Yes
    winbind enum users = Yes
    winbind nss info = rfc2307
    winbind offline logon = Yes
    winbind refresh tickets = Yes
    winbind use default domain = Yes
    workgroup = ********
    idmap config physcip: unix_nss_info = no
    idmap config physcip: unix_primary_group = no
    idmap config physcip: schema mode = rfc2307
    idmap config physcip: range = 500-90000000
    idmap config physcip: backend = ad
    idmap config *: range = 1-499
    idmap config * : backend = tdb
    acl allow execute always = Yes
    create mask = 0666
    directory mask = 0777
    directory name cache size = 0
    dos filemode = Yes
    ea support = Yes
    store dos attributes = Yes
    strict locking = No


[home]
    path = "/mnt/home"
    read only = No
    veto files = /.snapshot/.windows/.mac/.zfs/
    vfs objects = netatalk catia zfs_space zfsacl fruit streams_xattr
    zfsacl:acesort = dontcare
    nfs4:chown = true
    nfs4:acedup = merge
    nfs4:mode = special

Has someone reading this experienced similar problems or has any idea what I am missing here?

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.