2

I have been using Sandisk Ultra usb 3.0 pen drive since Jan, 2016. I live in Mumbai. But previous month, I created bootable usb with mac os Mojave. Then I formatted pen drive. Dont know what happened, since then the pen drive is not appearing on the desktop screen. In the disk utility, the pendrive is showing but its main partition is faded out. In the info box, it is showing, Mount Point: Not Mounted. I ran first aid, it is showing good condition. Then I clicked on mount in the diskutility selecting the faded out partition, nothing happened.

Various formating of pen drive imageswhen the faded out partition of the pendrive selected, I tried to erase with mac os journaled, it says, can not create file system on /dev/disk1s2 and below it, it was written 'permission denied' and at the bottom, it was written, file formatter failed.

I tried to erase the disk with erase disk but no result, some error message is appearing.

If I try to format in windows 10 then error message says the disk is write protected.

Note: Currently I am using mac os x, El capitan IMAC.

Please look into the picture for more details.

Please guide me to get back the pen drive functioning properly. Thanks in advance.

2

Your USB stick may be defective.

How do I fix a Write Protect error?

Write protection errors occur when a flash drive detects a potential fault within itself. The drive will go into write-protected mode to prevent data loss. There is no method to fix this. To verify the issue is related to the flash drive and not your computer we recommend that you try plugging the USB drive into another port on your computer. You should also try the drive on another computer if possible.

Source: https://kb.sandisk.com/app/answers/detail/a_id/8656/~/write-protect-error-on-usb-flash-drives

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.