1

I recently noticed that some of the applications cannot be started from Spotlight anymore. They show up correctly in the search results but then hitting return doesn't do anything (other than closing the Spotlight dialog that is). Indexing is turned on and I already tried re-indexing.

This is on High Sierra 10.13.6.

Update

It happened only with a handful of 3rd party apps so far. A pattern emerged:

  • Update an app which replaces an existing .app (i.e. same name) → Spotlight shows the OLD version as per "Version: xyz", I guess that's the reason it won't start
  • Update an app where the new version's .app has a different name e.g. rebranding and delete the old .app → Spotlight shows the old AND the new version, the new one can be started
  • See support.apple.com/en-gb/HT201716 – user310476 Jan 11 at 7:46
  • Thanks but as I said I already rebuilt the index. – Marcel Stör Jan 11 at 9:45
  • Does it happen with 3rd Party Apps AND preinstalled Apps (like TextEdit, Mail, ...)? – Kevin Grabher Jan 11 at 19:59
  • @KevinGrabher good point, I updated the question – Marcel Stör Jan 11 at 20:58
  • If you select an old version and hit cmd + return it should open the location in finder. Does that work? If yes, where does it go? – Kevin Grabher Jan 11 at 21:21
0

I ran the following commands (again) yesterday and they didn't seem to fix the issue

sudo mdutil -i off /
sudo rm -rf /.Spotlight-V100
sudo mdutil -i on /
sudo mdutil -E /

Then this morning macOS wanted to install some updates* and everything is back to normal now.

* a Safari update asked me to terminate "Spotlight.app" first, I found that odd because the only way to do this (to my knowledge) is through CLI or Activity Monitor

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .